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What is Arduino?Open-Source
Hardware Platform
Software (Arduino IDE)

Website: www.arduino.cc

http://www.arduino.cc/


  

Atmega328P microcontroller

Very small
Very low power computer
2KB RAM



  

Some applications

Microwave Oven                                   Modern Cars



  

Arduino board and IDE

Arduino board compatible                        The IDE



  

Materials
GizDuino S E or S tudent Edition (Arduino UNO)

   2 pins Tact Switch 
 10K Ohms 1/4W Resistors

   Red,Green,Blue LED 5mm
   470 Ohms 1/4W Resistors

   DHT11 Temperature and Humidity sensor

   HC-SR04 Distance sensor

  5V Relay Module Active-Low

  2-channel Tiny Motor Driver Module

  DC Motor

  Servo motor SG-90 160 degrees

  2X16 LCD Blue back light with I2C

  Passive Buzzer
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I. Introduction to gizDuino SE
What is gizDuino SE or Student Edition?
– It is an Arduino UNO compatible board.
– It has CH340 Driver and needed to install manually.
– It is Ardino Compatible Shield



  

gizDuinogizDuino  SESE
- is 100% code compatible with Arduino UNO. It is built for the budget but with the- is 100% code compatible with Arduino UNO. It is built for the budget but with the
Best possible quality. To obtain to most competitive price, we used the same USBBest possible quality. To obtain to most competitive price, we used the same USB
Bridge CH340 universally used by China UNO compatible manufacturers.Hence,Bridge CH340 universally used by China UNO compatible manufacturers.Hence,
If you are already user of these boards, you can switch to the gizDuino UNO-SEIf you are already user of these boards, you can switch to the gizDuino UNO-SE
And not notice a difference in usage.And not notice a difference in usage.

- Genuine ATMEL AVR with ATMEGA328P MCU Core- Genuine ATMEL AVR with ATMEGA328P MCU Core
- 100% Code compatible- 100% Code compatible
- CH340 USB to UART bridge. - CH340 USB to UART bridge. 



  

Parts and Descriptions



  

Microcontroller:  Microcontroller:  ATMEGA328P
                                                          

Power Input (DC): Power Input (DC): USB (+5V), External (7~12V)

Input Voltage (limits):Input Voltage (limits): 6~20V

DC Current per pins: DC Current per pins: 40mA

Digital I/O Pins: Digital I/O Pins: 20 Digital (6 for PWM)

Analog Input Pins: Analog Input Pins: 6

Hardware Serial Pin: 1

Flash Memory: Flash Memory: 32KB (2KB used by boot loader)

General Specifications



  

Arduino IDE

Drivers Install this first!

www.e-gizmo.net/oc/kits documents/ARDUINO IDE SOFTWARES
 Choose your Arduino IDE for your OS.

http://e-gizmo.net/oc/kits%20documents/CH340%20USB-TTL/drivers.zip

     Software Arduino IDE installation

http://www.e-gizmo.net/oc/kits


  

USB Connector

USB Cable

Open Arduino IDE.

Connect the
gizDuino SE to PC



  

On the Arduino IDE.
1. BLINK codes
    Go to File> Open > BLINK.ino

2. Board select
     Go to Tools>Boards>Arduino UNO

3. Port select
     Go to Tools>Port>COM#
Select the correct port
Go to Device Manager
      if you're not sure.

Upload BLINK.ino



  

II. Basic structure

setup()  
- is called when a sketch starts.
- it will only run once , after 
power up or reset the device.

Loop()
- loops consecutively.
- active ly control the  Arduino 
device .

//
- a s ingle  line  comment begins 
with // (two adjacent slashes)

/**/
- a block or multi-line  comment
Is marked by the symbol /* and 
the symbol */



  

Digital I/O and Time Functions

LED_BUILTIN 
= 13 or Digital pin 13

digitalWrite(pin,value);  
Pin: arduino pin number to set 
mode of.
Value: HIGH or LOW

delay(ms);
ms: the number of milliseconds 
to pause.
1000ms  = 1second

pinmode(pin,mode); 
Pin: arduino pin number to set 
mode of.
Mode: INPUT,OUTPUT or 
INPUT_PULLUP.



  

Output devices  
(Digital/PWM)(Digital/PWM)
LED LightsLED Lights
TransistorTransistor
BuzzerBuzzer
Servo Servo 
DC Motor DC Motor 
StepperStepper
RelayRelay

Input devices  
(Digital/Analog)(Digital/Analog)
Push ButtonsPush Buttons
ADC (Analog to Digital Converter)ADC (Analog to Digital Converter)
LDR (Light Dependent Resistor)LDR (Light Dependent Resistor)
Temperature Sensor Temperature Sensor 
Weight sensorWeight sensor
Compact ProximityCompact Proximity
Voltage MeasurementVoltage Measurement
PositionPosition

Serial Communication devices 
(RX/TX/Modules/Shields/I2C)(RX/TX/Modules/Shields/I2C)
GSM (Text/Call)GSM (Text/Call)
GPS (Location)GPS (Location)
WiFi (ESP8266,LoRa)WiFi (ESP8266,LoRa)
Bluetooth (HC-05,HM-10..)Bluetooth (HC-05,HM-10..)
RF Modules (UHF)RF Modules (UHF)
FingerprintFingerprint
Industrial Equipment with Serial ConnectionsIndustrial Equipment with Serial Connections
RFIDRFID
LCD,RTC I2CLCD,RTC I2C

SPI Communication devices 
(MOSI/MISO/SCK/CS)(MOSI/MISO/SCK/CS)
SD Card Shields (Data logging)SD Card Shields (Data logging)
Ethernet Shield (ENC,Wiznet)Ethernet Shield (ENC,Wiznet)
OLED DisplayOLED Display

What are those devices use in __?



  

III. Exercises



  

Part 1. LED Blinking
Manual Wiring

This part shows you how to manually
Wiring the LED, Resistor to gizDuino.

Upload the LEDBlinking.ino.



  

The code

pinmode(pin,mode); 
Pin: arduino pin number to set 
mode of.
Mode: INPUT,OUTPUT or 
INPUT_PULLUP.

digitalWrite(pin,value);  
Pin: arduino pin number to set 
mode of.
Value: HIGH or LOW

delay(ms);
ms: the number of milliseconds 
to pause.
1000ms = 1second

#define constantName value
constantName: the name of 
the macro to define.
value: the value to assign to the 
macro.



  

How to use the breadboard.

Vertically || 
connected

Horizontally Connected =
For Power Supply
Extensions
- GND
+ VCC

For Components
Space such as
LED, resistor,
Sensors with male
Connectors and
J umper wires.



  

LED polarity
LED 5mm Blue

(-)
(+)

470 ohms 1/4W
Resistor
- has no polarity

Positive
or AnodeNegative

or Cathode

Flat side

Longer leg pin



  

Part 2. Multiple LEDs
DigitalPin 8,9,10,11,12

1. Blink all the LEDs
2. Do the Running Light

Upload the code
1. MultipleLEDs2.ino
2. RunningLEDLights2

See what happends?



  

The code (multiple use)

pinmode(pin,mode); 
Pin: arduino pin number to set 
mode of.
Mode: INPUT,OUTPUT or 
INPUT_PULLUP.

#define constantName value
constantName: the name of 
the macro to define.
value: the value to assign to the 
macro.

Note: 
Always  add the  pinMode  on 
each pin you will use  e ither 
OUTPUT or INPUT.



  

The code

digitalWrite(pin,value);  
Pin: arduino pin number to set 
mode of.
Value: HIGH or LOW

delay(ms);
ms: the number of milliseconds 
to pause.
1000ms = 1second

Note: 
If you are  us ing Digital pin as  
Output use  digitalWrite.



  

The code (for loop)

for(initialization; condition; 
increment){
// statement(s);
}
I
Where:
Initialization: i = 0; //start
Condition: < (less than), > (greater than), <= 
(less than equal), >= (greater than equal)
Increment: ++ ,-- ,+=,-=

int var = val;
var: variable name
val: the value you assign to that 
variable.

Inside the loop, you can add
The Functions()/ statements



  

The code (add more functions)

for(initialization; condition; 
increment){
// statement(s);
}
I
Where:
Initialization: i = 0; //start
Condition: < (less than), > (greater than), <= 
(less than equal), >= (greater than equal)
Increment: ++ ,-- ,+=,-=

int var = val;
var: variable name
val: the value you assign to that 
variable.

The 5 LED was
assigned in 8,9,10,11,12
as 0,1,2,3,4 for loop.



  

Part 3. Latch and Push Button switch
Connections:
LED Blue → D11        Button 1: D3
LED Red  → D10        Button 2: D2

Upload the Latch Switch Button.ino.



  

The code
int var = val;
var: variable name
val: the value you assign to that 
variable.

LEDs pin 11 and 10
Switches pin 3 and 2
The switch state is 0 or LOW
If it is pressed,
But in normal situation the
Switch value is HIGH.
LED state is 0, for switch 
case statement.
 - controls the flow of 
programs by allowing 
programmers to specify 
different code that executed 
in various conditions.



  

The code
pinmode(pin,mode); 
Pin: arduino pin number to set 
mode of.
Mode: INPUT,OUTPUT or 
INPUT_PULLUP.



  

The code
Switch Case:
- controls  the  flow of programs 
by allowing programmers  to 
specify different code  that 
executed in various  conditions . .

while:
- while  loop will loop 
continous ly, and infinite ly, until 
the  express ion ins ide  the  
parenthes is , () becomes  false .

If statement:
- checks  for a condition and 
executes  the  following 
s tatement or se t of s tatements  if 
the  condition is  'true '.



  

Part 4. Passive Buzzer
Connections
Passive Buzzer
VCC → 5V
I/O → D9
GND → GND

Upload the Passive Buzzer.ino.



  

The code
#include “pitches.h”
- is used to include outside libraries in 
your sketch.

#define constantName value
constantName: the name of 
the macro to define.
value: the value to assign to the 
macro.

tone(pin, frequency)
tone(pin,frequency,duration
) 
frequency: the frequency of the 
tone in hertz
duration: the value to assign to 
the macro.



  

Part 5. Relay
Connections:
Relay → gizDuino
IN → Digital pin 5
VCC → +5V
GND → GND

Upload the code RELAY.ino.

Its actually a blinking LED on
Digital Pin 5. Once the Ouput
Is LOW the relay will trigger its
Contact.

See what happends?

Relay is Active-LOW.



  

The code

Check/test the relay, if it is 
Active-Low when you put 0/GND 
to the Input pin, it will trigger the 
relay contacts from Normally 
Open to Closed. Vice versa, 
with Active-High.

On this sample code, every 1 
sec the pin 5 is blinking. If you 
see the LED indicator ON the 
relay triggered. OFF if not.

Relay pin is on Digital Pin 5
LED indicator is Digital Pin 4



  

Part 6. Temperature and
 Humidity Sensor

Connections:
DHT11 → gizDuino
VCC → +5V
OUT → Digital pin 12
GND → GND

First, read the nextslide on how to add
A DHT11 library.

Upload the DHT11breakout_sample_sketch.

Check the temperature and humidity
Value on the Serial Monitor.

See what's the results?



  

Libraries is available in our site.

When you download a library, 
The file is compressed in zip 
file.
So,Extract the file.

Get the DHT folder which 
contains :
- examples >.ino file
- DHT.cpp
- DHT.h
- Keywords.txt

There are two library folder to choose from and here's 
the path. (Choose Only 1)
1. My Documents>Arduino>libraries>DHT
2. Arduino 1.8.13>libraries>DHT

How to add a DHT Library

Note:
The filename and its file inside
must be the same name in cpp
and h files .



  

The code

In setup section:

Serial.begin(9600);
S erial.begin(speed)
S erial.begin(speed,config)
- sets the date rate in bits per seconds 
(baud) for serial data transmission. For 
communicating with Serial Monitor.

Serial.println(“DHTXX TEST!”);
S erial.println(val)
S erial.println(val, format)
- prints date to the serial port as human-
readable ASCII text followed by a 
carriage return character (ASCII 13, or'\r') 
and a newline character (ACII 10,'\n').

dht.begin();
- the included library has need to 
Set the begin function inside the setup.

#include “DHT.h”
- is used to include outside libraries in 
your sketch.

Next to pin assigning DHTPIN is on 
Digital Pin 12



  

The code
In loop section:

float var = val;
var: variable name
val: the value you assign to that variable.
- datatype for floating-point numbers, a 
number that has a decimal point.

if (condition){
//statements(s)
}
Condition: a boolean expression
(true or false)

return;
- terminate a function and return a value 
from a function to the calling function, if 
desired.

Serial.println(); - refer to previous slide.



  

Serial Monitor

Open the Serial Monitor by clicking the 
icon on the right top corner in Arduino 
Ide.

If the sensor is not properly connected
it will display failed to read from dht 
sensor.

This should be the correct output 
displayed on the Serial Monitor.



  

Part 7. Distance Sensor
Distance Sensor → gizDuino
Vcc → +5V
Trigger → Digital Pin 11
Echo → Digital Pin 12
Gnd → GND

Make sure you add the NewPing library.

File>Examples>NewPing>examples>
NewPingExample.

Open the Serial Monitor.

Check the value.

See what happends, if you block
Something on the front of the sensor?



  

The code

#include <NewPing.h>
- is used to include outside libraries in 
your sketch.

Trigger pin is Digitial Pin 12
Echo pin is Digitial Pin 11
Maximum Distance is 200 (cm) unit



  

The code

Serial.begin sets to 115200 baudrate.
When you open the serial monitor
Go to this section select the correct 
baudrate 115200 bps

usigned int var = val;
var: variable name
val: the value you assign to that variable 

Serial.begin sets to 115200 baudrate.
When you open the serial monitor
Go to this section select the correct 
baudrate 115200 bps

Serial Monitor display



  

Part 8. Servo Motor

Servo → gizDuino
SIGNAL (Yellow/orange) → Digital Pin 9
GND(Black/brown) → GND
VCC(Red) → +5V

Upload the ServoSweep.ino

Question? Why do we need a
Servo Motor?

See what happends?



  

The code
       
#include <Servo.h>
- is used to include outside libraries in 
your sketch.

Servo object name;
- name it your servo

int pos = 0;
- we create variable with start to 0 degree 
position.

servo.attach(pin);
servo.attach(pin,min,max);
- attach the servo variable to a pin.



  

The code

for(initialization; condition; 
increment){
// statement(s);
}
I
Where:
Initialization: pos = 0; //start
Condition: < (less than), > (greater 
than), <= (less than equal), >= (greater 
than equal)
Increment: ++ ,-- ,+=,-=

servo.write(angle);
angle: the value to write to the servo, 
from 0 to 180 degrees.



  

Part 9. Servo Motor

Motor Driver → gizDuino
IN1 → Digital Pin 8
IN2 → Digital Pin 9
+VM → +5V
GND → GND

DC Motor → Motor Driver
Pin1 → 1A
Pin2 → 1B

Upload the 2ch_tiny_motor_sample_code.

Question? Why do we need a Motor Driver?

See what happends?



  

The code
In gizDuino LIN-UNO the PWM pins are 
Digital Pin 3,5,6,9,10,11.
9 and 10 are PWM pins for 
controlling the speed from 0-255.
0 means stop, 255 full-speed

While
8 and 11 are assigned for switching 
the directions of the motor.

On this example, used digitalWrite for the 
direction and analogWrite for the speed.



  

Part 10. LCD Display with I2C module
LCD w/ I2C → gizDuino
Gnd → GND
Vcc → +5V
SDA → A4/Digital Pin 18/SDA
SCL → A5/Digtial Pin 19/SCL

Make sure the 
LiquidCrystal_I2C library is added.
Upload the code LCDI2C.

See what happends?



  

The code
Wire and LiquidCrystal_I2C added.

This is with I2C module so the 
i2c address  is 0x27

Set the baudrate to 9600 bps.
lcd.begin(16,2);
16: number of columns
2: number of rows
With the 32 characters display in total.



  

The code
LCD backlight blinks 4 times every 
250ms delay

lcd.backlight();
- it stick to backlight on.

lcd.setCursor(0,0);
- set the cursor on the origin (0,0), 
column, row.

lcd.print(“Hello, world!”);
- it displays on the LCD.

lcd.clear();
- clear out/erase all the display.



  

The code

Serial.availabe()
- get the number of bytes (characters) 
available for reading from the serial port.

lcd.write(Serial.read());
- writes binary data to the serial port.
- it prints the read data to lcd display.

Serial.read();
- reads incoming serial data



  

For more info:

  Website: www.e-gizmo.net
 Egizmo Tech blog:https://www.e-gizmo.net/oc/index.php?route=journal3/blog
 Facebook: eGizmoMechatronix
 Youtube Channel: e-Gizmo Mechatronix Central
 Shopee: eGizmo

http://www.e-gizmo.net/
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