
  

PBOT2018
MANUAL GUIDE

FUNCTIONS :
PBOT 2018
  
> Line follower
 

                  > Maze Solver

  > Collision Avoidance
  

> Sumo fight

Included:
- USB Cable Type A to mini B
- 5V 1A adaptor



  

PBOT 2018
DESCRIPTIONS

VARIANTS:
 PBOT2018
 

 

> Line follower

 
> Maze Solver

 > Sumo fight

>Optional
- Add wireless devices

- has new comptible PBOT 2018 Board and gizDuino 168
  Microcontroller for basic entry level robot functions and open
  Circuit board. The Open circuit enables the user to boarden the 
  Capabilities of prototyping by adding certain peripheral to the
  Board.
- to follow the black line on the track from start to finish line. It has 
   Digital line calibration to make it easy.

- to solve the maze courses, you can upload the sketch given or modify
   It to remote control via wireless devices (Optional).

- to fight with other opponents robots with in the ring, it has line/
  Outside avoidance.

- you can add bluetooth, PS2 controller with UHF STD, Wifi.. etc
   to control it wirelessly.



  

PBOT 2018
SPECIFICATIONS
General Specifications:
  Battery: 3.7V Li-Ion 1650mAh rechargeable
 On-board Peripherals: 
  - IC Atmega168 w/ 16KB Flash memory
  - IC A3966 Dual Full-bridge PWM Motor Driver
  - 2-Ch DC Motor 6V geared 1.5A
  - 3-Ch IR line sensor CNY70,10mm range
  - 3-Ch IR proximity sensor 2-4inches range
  - 4-Ch servo output.
  - Bluetooth/Wireless Expansion port
  - Built-in Li-ion Battery Charger
 PCB Dimensions: 62 mm x 67 mm
 
 
 
* Note: Analog pins A4 and A5 are used to
interface with the system controller, hence
are not available for user shields/application.

Features:
- Basic Arduino Programming, Include
eGizmo_PBOT2018 library.
The operation of motor to its maximum power
- Efficient Motor Driver circuitry enables
The operation of motor to its maximum power
At the same time eliminating the need for
An heatsink.
-On board 4 ch servo motor driver port
-Sensor managed by independent controller
-Collision sensor are pulsed to saved battery
Power.
-Line sensors are digitally calibrated making
Calibration process delightfully easy
-Arduino Compatible
-Program it using Arduino IDE 100% code
Compatible
- 3-4hours charging full
-Arduino external I/O pin layout allows you to
Plug in any Arduino compatible Shield*



  

PBOT 2018 BOARD
MAJOR PARTS



  

LINE SENSOR
LINE FOLLOWER CONNECTIONS

LINE SENSORS CONNECTION (P7):
                                GND,DRV,LN3,LN2,LN1

LINE SENSOR ARRAY:

 3 channel Line sensors

LINE CAL – for making line sensor calibrated as easy.
                                    (to calibrate read the page 5) 

LINE SENSOR LED INDICATORS:
 - LN3(D13), LN2(D12),LN1(D11)
 - if LED is ON, black color detected
 - if LED is OFF, white color detected



  

Softwares and library

Arduino IDE

Drivers Install this first!

Library Add to My Documents>Arduino>libraries

www.e-gizmo.net/oc/kits documents/ARDUINO IDE SOFTWARES
  Download Arduino 1.8.5 egizmo themes new (Windows)
  Choose your Arduino IDE for your OS.

www.e-gizmo.net/oc/kits documents/ARDUINO IDE SOFTWARES
  Download Prolific Driver v10.0 (Windows)
 (For Mac OS users) Download md_PL2303_MacOSX

www.e-gizmo.net/oc/kits documents/PBOT2018
  Download eGizmo_PBOT2018.zip (Unzip this before you move to libraries)

http://www.e-gizmo.net/oc/kits
http://www.e-gizmo.net/oc/kits
http://www.e-gizmo.net/oc/kits


  

Setting Up your Arduino IDE with
Ardublock



  

Downloads
ArduBlock MOD:
“Ardublock-060118.jar”

Go to My Documents>Arduino. 
Create filename “tools” folder then “ArduBlockTool” folder and “tool” folder. 
Inside the tool folder place the “ardublock-060118.jar“.

Now Open your Arduino 1.8.5 IDE.



  

Open the ArduBlock
The Ardublock shown in Tools list > Click ArduBlock. Done



  

Familiarize with Blocks
THE IDE



  

Basic Block
CONTROLS
 - sketch, control structures
 - loop
- delays (millis)
-  if 
- if else
- while
- do while 
- repeat 
- break



  

Basic Block
PINS [FUNCTIONS]
 - Digital I/O, Analog I/O, Time,Advanced I/O
 - read digital pin
- analog pin(INPUT)
- set digital pin(OUTPUT)
- analog pin 
- servo 
- ultrasonic
- Dht11
- tone 
- set digital 8pins (0-7)



  

Basic Block
TESTS
 - Comparison Operators,Boolean Operators
 - greater than
 - less than 
 - equal to 
 - greater than equal to
 - less than equal to 
 - not equal to…



  

Basic Block
MATH OPERATORS
 - Arithmetic Operators, Math, Random Numbers
 -addition,subtraction, multiplication, 
division, remainder,absolute, power,
square root, sine, cosine, tangent,random…



  

Basic Block
VARIABLES/CONSTANTS
 - Constants, Conversion
 - Set integer variable,unsigned long, string, 
boolean, low, high, true, false, double, int, byte, char…



  

Basic Block
COMMUNICATION
 - Serial communication, Stream,Print,
    Serial read/write
 - Serial data available,serial read,
     serial parseInt, Serial write, Serial print,…



  

For PBOT2018 blocks
E-GIZMO PBOT2018 BLOCKS (USE FOR NEW PBOT BOARD)
 



  

Connect the PBOT to PC

USB Connector

USB Cable

Open Arduino IDE.



  

Uploading Linebot.ino
For line followerOn the Arduino IDE.

1. Line Follower codes
    Go to File>Examples>eGizmo_PBOT2018>LINEBOT

2. Board select
     Go to Tools>Boards>gizDuino (mini) w/ Atmega168

3. Port select
     Go to Tools>Port>COM#
 Select the correct port
 Go to Device Manager
if you're not sure.

Tips for uploading:
   Press and Hold the  SYS RST (SW3)
switch ON the power and
Click Upload. Release RST
when done.

SYS RST POWER SW



  

LINE SENSOR
CALIBRATION1,2

 1. After uploading your code for linesensors.
     Turn OFF the POWER switch.

2. Place the eGizmo PBOT controller to the "black
     line" then

Turn 
Off

A.

B.

C.
Turn On

Press and Hold LINE CAL and SYS RST,
     while pressing and holding the buttons,

Turn ON the POWER Switch. 

LN2 (D12 LED indicator) is ON.



  

LINE SENSOR
CALIBRATION 3

3. First RELEASE the SYS RST followed by LINE CAL.
      Make sure the 3CH Line sensors are faces on the
      "black line" 

and you will see the LN1 and LN3
(D11 and D13 LED indicators) are
 Turn ON and LN1 is blinking. 

Now Press LINE CAL  once
for the black color calibration.



  

LINE SENSOR
CALIBRATION 4,54. Next, if the L3 (D13 LED indicator) is blinking.

     Place the 3CH Line sensors on the "White track".

Then Press LINE CAL again once for the 
white color calibration.

After that you will see all the LEDS
      for linesensors are ON.

5. Now your eGizmo PBOT Controller 
      Linesensors  are calibrated. Then 
      Press the RESET button or
      Switch off and turn ON again.
     You can now  trace the line and DONE.



  

LINE FOLLOWER SYNTAX
SYNTAX

 PBOT.LS1_LEFT();
 PBOT.LS2_CENTER();
 PBOT.LS3_RIGHT();

OUTPUT
 WHITE LINE DETECTED = 0 or LOW
 BLACK LINE DETECTED = 1 or HIGH

EXAMPLES;

If (PBOT.LS2_CENTER() == HIGH) //  if line sensor 2 center is high
{
Serial.println(“Black line detected!”);
}

LS1
LS2

LS3



  

START WITH ADDING A BLOCK “PBOT BEGIN”

Adding PBOT BEGIN block – settting up the eGizmo_PBOT2018,
 Wire library and turn ON all the motors.



  

SERIAL MONITOR BY ADDING THE SERIAL PRINT BLOCK



  

USE THE DROP-DOWN ARROW TO SELECT SENSOR

Click the Dropdown arrow to select immediately the line sensor

As you can see the 3 line sensors appears



  

FOR BLACK LINE SENSING

LEFT



  

FOR BLACK LINE SENSING

CENTER



  

FOR BLACK LINE SENSING

RIGHT



  

FOR WHITE LINE SENSING

LEFT



  

FOR WHITE LINE SENSING

CENTER



  

FOR WHITE LINE SENSING

RIGHT



  

MOTORS
CONNECTION SECTION

MOTOR WIRE CONNECTIONS (P2):
         MOT 1 – 1A,1B ; MOT2 – 2A,2B

MOT 1 = LEFT
Blue-Bottom
Yellow-Upper

MOT 2 = RIGHT
Green-Upper
Black-Bottom

*Please don not depends on the color of the wires.
  Follow the location of it. 



  

Uploading Motor Test.ino
Direction/SpeedOn the Arduino IDE.

1. Motor controls codes
    Go to File>Examples>eGizmo_PBOT2018>MOTOR_TEST

2. Board select
     Go to Tools>Boards>gizDuino (mini) w/ Atmega168

3. Port select
     Go to Tools>Port>COM#
 Select the correct port
 Go to Device Manager
if you're not sure.

Tips for uploading:
   Press and Hold the  SYS RST (SW3)
switch ON the power and
Click Upload. Release RST
when done.

SYS RST POWER SW



  

MOTOR CONTROLS SYNTAX
SYNTAX

Set motor direction:

 PBOT.DIRECTION(whichmotor,dir);
where: 
      whichmotor = MOTOR_A or MOTOR_B, MOTOR_BOTH
      dir =  MOTOR_FWD,MOTOR_REV

EXAMPLES;

PBOT.DIRECTION(MOTOR_BOTH, MOTOR_FWD); // Move Forward
PBOT.SPEED(MOTOR_BOTH, 80);

Set motor speed:

 PBOT.SPEED(whichmotor,speed);
where: 
      whichmotor = MOTOR_A or MOTOR_B, MOTOR_BOTH
       speed =  0 to 255, 0 = Full Stop, 80 = Neutral,255 = High, limit 250



  

START WITH ADDING A BLOCK “PBOT BEGIN”

Adding PBOT BEGIN block – settting up the eGizmo_PBOT2018,
 Wire library and turn ON all the motors.



  

Move Forward

Motors forward at 120 PWM speed in 2 secs



  

Reverse Motors

Motors reverse at 120 PWM speed in 2 secs



  

Turn Right

Motors A turning right at 120 PWM speed in 2 secs



  

Turn Left

Motors B turning left at 120 PWM speed in 2 secs



  

Motor Stops

Both Motor stops at 0  speed in 2 secs



  

Extreme Right

Motors A forward and Motor B  reverse at 120 PWM speed in 2 secs



  

Extreme Left

Motors A reverse  and Motor B forward at 120 PWM speed in 2 secs



  

MAZE/SUMO
IR SENSORS CONNECTIONS

IR RECEIVERS 38Khz
  - U5, U6, U7

IR LED TRASMITTER
   - D17, D18, D19
   -  Distance Range: 2 – 4 inches

IR LED INDICATORS
  - COL1 (D14), COL2 (D15), COL3 (D16)
  - if LED is ON, Object detected
  - if LED is OFF, No object detected



  

Uploading Maze.ino
Maze SolverOn the Arduino IDE.

1. Maze Solver codes
    Go to File>Examples>eGizmo_PBOT2018>MAZE

2. Board select
     Go to Tools>Boards>gizDuino (mini) w/ Atmega168

3. Port select
     Go to Tools>Port>COM#
 Select the correct port
 Go to Device Manager
if you're not sure.

Tips for uploading:
   Press and Hold the RST (SW3)
switch ON the power and
Click Upload. Release RST
when done.



  

Uploading Sumo.ino
Sumo FightOn the Arduino IDE.

1. Sumo fighting codes
    Go to File>Examples>eGizmo_PBOT2018>SUMO

2. Board select
     Go to Tools>Boards>gizDuino (mini) w/ Atmega168

3. Port select
     Go to Tools>Port>COM#
 Select the correct port
 Go to Device Manager
if you're not sure.

Tips for uploading:
   Press and Hold the RST (SW3)
switch ON the power and
Click Upload. Release RST
when done.



  

IR SENSORS SYNTAX
SYNTAX

 PBOT.COL1_RIGHT();
 PBOT.COL2_CENTER();
 PBOT.COL3_LEFT();

OUTPUT
 NO OBJECT DETECTED = 0 or LOW
 OBJECT DETECTED = 1 or HIGH

EXAMPLES;

If (PBOT.COL2_CENTER() == HIGH) //  if IR sensor 2 center is high
{
Serial.println(“Object detected!”);
}

!



  

START WITH ADDING A BLOCK “PBOT BEGIN”

Adding PBOT BEGIN block – settting up the eGizmo_PBOT2018,
 Wire library and turn ON all the motors.



  

SERIAL MONITOR BY ADDING THE SERIAL PRINT BLOCK



  

USE THE DROP-DOWN ARROW TO SELECT SENSOR

Click the Dropdown arrow to select immediately the collision sensor

As you can see the 3 IR collision sensors appears



  

FOR OBJECT DETECTION

RIGHT



  

FOR OBJECT DETECTION

CENTER



  

FOR OBJECT DETECTION

LEFT



  

SERVO
CONNECTION

Servo labels  #1-#4

Servo connectors from P3 - P6

Servo Supply J2



  

Uploading Servo sweep.ino
Servo ControlsOn the Arduino IDE.

1. Servo codes
    Go to File>Examples>eGizmo_PBOT2018>
    Servo_Sweep

2. Board select
     Go to Tools>Boards>gizDuino (mini) w/ Atmega168

3. Port select
     Go to Tools>Port>COM#
Select the correct port
Go to Device Manager
if you're not sure.

Tips for uploading:
  Press and Hold the RST (SW3)
switch ON the power and
Click Upload. Release RST
when done.



  

SERVO SYNTAX
SYNTAX

PBOT.SERVO(whichSERVO,pulsewidth);
where:
            Whichservo = 1 to 4, ignore other values
            Pulsewidth = 0 to 180 (degrees)
                                          - value less than 500 stops the Servo PWM generator
                                          - the pulsewidth converted to degrees from 0 to 180 (default)

EXAMPLES;

PBOT.SERVO(1, 15);
delay(1000);
PBOT.SERVo(1, 90);
delay(1000);



  

START WITH ADDING A BLOCK “PBOT BEGIN”

Adding PBOT BEGIN block – settting up the eGizmo_PBOT2018,
 Wire library and turn ON all the motors.



  

For Servo Blocks

Double Click the block 1 to change the servo number
 also the 90 degrees to change it.

Upload to Arduino. This will shown on the IDE. ”



  

For more info:
  Website: www.e-gizmo.net
 Egizmo Tech blog:www.e-gizmo.com/wp
 Facebook: eGizmoMechatronix
 Youtube Channel: e-Gizmo Mechatronix Central

http://www.e-gizmo.net/
http://www.e-gizmo.com/wp
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