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Description

 The AT32UC3C is a complete System-On-Chip
microcontroller based on the AVR32UC RISC

processor running at frequencies up to 66 MHz.

* |s a high-performance 32-bit RISC
microprocessor core, designed for cost-
sensitive embedded applications, with particular
emphasis on low power consumption, high
code density and high performance.



a descendant of the s, which are both come from
Atmel and you can use the same Atmel Studio IDE with free
C/C++ compiler.

Arduino chose the ARM cortex MO based SAMD21 device
instead of the AVR32 for their next generation 32-bit Arduino
Zero board.

Nevertheless there are advantages of the AVR32, unlike the
SAMD21, the AVR32 comes preprogrammed with a bootloader.
So yo can load your program without a programmer. AVR32
comes with USB host and device interface and an Ethernet
MACSB interface. So it is closer than the Arduino Zero to
implementing IOT projects.

According to motion55 @elab.ph forum “The AVR32 Tutorials”
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« ltis basically an AT32UC3C264C or AT32UC3C2128C mounted
on a small board with connectors to access all pins (breakout), a
JTAG connector for debugging and programming and a mini USB

(OTG) connector. There is also a 12MHz crystal needed for USB
clocking.

 The I/O connectors are standard 0.1 pitch connector so you can

In turn mount the mini board over a prototyping board for your
projects.



Schematic Diagram

* https://e-gizmo.net/oc/kKits
%20documents/AVR32/New%20AVR32/The
%20%20AVR32/schematic.gif



Software Downloads

* Microchip Studio for AVR and SAM devices

* https://www.microchip.com/en-us/development-
tools-tools-and-software/microchip-studio-for-
avr-and-sam-devices

* Microchip official website
 https://www.microchip.com/



e FLIP installer (to use the bootloader

* https://e-gizmo.net/oc/kits
%20documents/AVR32/New%20AVR32/The
%20%20AVR32/
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Specifications

MCU boards Program SRAM I/0 pins
Memory

AT32UC3C264 64KB 16KB 45

AT32UC3C2128C 128KB 32KB 45

AT32UC3C2512C 512KB 64KB 45

Datasheet

Features

TWILUSART,SP
1,12C,2MSPS A
DC,DAC.ETHE
RNET,USB

(device + OTG)

http://ww1.microchip.com/downloads/en/DeviceDoc/doc32117.pdf




GPIO Controller Functions Multiplexing

AVR32_PIN_PAxx GPIO function
QFN PIN D

CANIF- PEVC-
RXLINE[1] PAD_EVTIO]

SCIF- EIC-
GLCKI[1] EXTINT[1]

ADCIN1 USBC-VBOF  ACIFAO-
ACBOUT

ADCIN3 AC1AN1 PEVC-
PAD_EVT[3]

ADCINS AC1BN1

14 ADC REFP

* see the GPIO Function summary



GPIO Function

AVR32_PIN_PAxx/PBxx GPIO function
QFN PIN A B c D E F

PA20 ADCIN9 ACOAPO ACOAPO or
DACOA

ADCIN11 ACOANO PEVC- MACB-
PAD_EVT[4] SPEED

PB00 USARTO- CANIF- EIC- PEVC-

CLK RXLINE[1] EXTINTI[8] PAD_EVTI[10]

PB30

* see the GPIO Function summary



GPIO Function

AVR32 PIN_PCxx

34 PCO03 TWIMSO- EIC- USART2- TC1-B1 MACB-MDIO
TWCK EXTINT[1] TXD

PCO05 TWIMS1- EIC- USART2- TCO0-A2
TWCK EXTINT[4] RXD

PC16 PWM- SPI0- EBI-CAS USARTO- CANIF-
PWML[1] NPCS[1] TXD TXLINE[1]

PC18 PWM- EIC- EBI-SDA10  1ISC-ISDI USART3-
PWML[0] EXTINT[5] RXD

PC20 PWM- SCIF- EBI-DATA[1]  IISC-ISCK USART3-RTS
PWMH[2] GCLK[1]

PWM- CANIF- EBI-DATA[3] USART3-CLK
EXT_FAULT  TXLINE[O]
S[1]

* see the GPIO Function summary



AVR32 PIN_PDxx GPIO Function

PDO1 SPI0-MISO TC1-A0 EBI-DATA[14] TCO-CLK1 USARTO-
RXD

PDO03 SPIO- TCO0-B2 EBI-ADDR[0] QDECO0-

NPCS[0] QEPB
PD12 USART1- USBC-VBOF  EBI-ADDR[9] PEVC- MACB-

PAD_EVT[7]  TXD[1]

PD14 USART1- EIC- EBI- PEVC- MACB-

RTS EXTINTI[7] ADDRI[10] PAD_EVT[9] RXD[1]
PD27 USARTO- CANIF- EBI-NCS[1] TCO0-A0 MACB-

TXD RXLINE[O0] RX_ER
PD29 USARTO- EIC- USARTO-CLK TCO0-CLKO MACB-

CTS EXTINTI[6] TX_CLK

* see the GPIO Function summary




*GPIO Function in summary

PORT A # PIN PORT C # PIN PORT D # PIN

TWI SCL SPI MISO

PCO05 TWI SCL

PA08 SPI CS4

SPI MOSI

SPI SCK

PORT B # PIN

PBO1




THE CODES




Pin assighment

. AVR32 PIN_PA0O - 09,16,19,20 — 23
. AVR32 PIN_PB00 - 01,30 - 31
. AVR32 PIN_PC02 - 05,15 — 22
+ AVR32 _PIN_PD00 — 03,11 — 14,21,27 - 30

- These are the GPIO mapping



MCU frequency

» #define BOARD OSCO0 STARTUP_US
50000
 #define BOARD_OSCO0 IS _XTAL true



-
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LET'S START with

LED BLINKING




Creating a new AVR32 project

?

Mew Project

b Recent »| &= = Search Installed Templates (Ctrl+E) P-
4 |nstalled -
- e: C/C
Creates an project for Atmel or User

Assembler Convert AVR GCC to XC8 Proj... C/C++ boards using ASF

Micrechip Studic Sclution
. GCC C ASF Board Project C/C++
C/C++

GCC C ASF Board Praject

GCC C Executable Project

\Desktoph AVR3Z FILESVFOR AVR32 KIT,

LED_BLIMKING

« Step 1. Launch Microchip* Studio and on the menu select File
> New > Project. The new project dialog will appear. On the
dialog, select “GCC C ASF Board Project”. Fill in the name
“LED_BLINKING” for the project and press OK.

*from ATMEL to Microchip brand name



Board Selection
'e) Select By Device | ) Select By Board Extensions Atmel ASF(3.51.0) ~
Device Family Al " uc3c2

App./Boot Memory (Kbytes)Data Memory (bytes)EEPROM (bytes)

AT32UC3C2512C 512

« Step 2. After Choosing “GCC C ASF Board Project”, select the
device. For the board sample | have, | select the
AT32UC3C264C.

« The Microchip Studio will then create the project
LED BLINKING in the desired location. So far this is standard
procedure when using the Microchip Studio.

* The next step will be to run ASF wizard to add the modules you
will be using on the project.



Using the ASF Wizard

After creating the project, take time to examine the contents.

nothing to do on this project in terms of execution, there's an
organization and file structure as shown. The center, you can
see the contents of the code. In this case it's the main.c file.
Except for the call to board_init(), it is blank at this point. If you
build (compile) this project,_it will compile without errors.

« Remember that the Microsoft company who created this IDE.
So if you want to add or cut the files. You can cut and paste
from Windows Explorer to the Solution Explorer will work.

* Another way is the ASF Wizard will allow you to automatically
add code developed by Atmel that can utilize the features of the
MCU. It is True,that you can also write your own code to access
the registers directly to operate the peripherals.



Use ASF wizard

Let's now use the ASF (Atmel Software Framework) Wizard. In

A

* On the left box, you can select the modules that you will need.
There's no case if you select modules that you don't need. It
can occupy space on the MCU but if it is fit don't you worry.

» Besides the linker might remove unused modules. Let's add the
following with BLINKING.

» 1. Delay routes (service)

2. IOPORT — General purpose I/O (service)

* Note: If you compile the code at this point there wil be an error
occurred and clearly we need to organize it.



ASF Wizard view

ASFWizard + X

Project:  GecBoardProject! Device: AT32UC3C264C

Extensions Yersion

Available Modules Selected Modules

Extensions: | Atmel ASF3.510) ¥ | Show: | Al Bl Generic board support (driver)

i B GFX Color - System Font (service)

I 8 GPIO - General-Purpose Input/Qutput (driver)
i B Graphical Widget Library Toolkit (service)

I BN ISC - Inter-IC Sound Controller (driver)

| ﬁ [JG JPEG Decoder (service)

el BT - Interrun nntroller (Hr

Select and Click Add>> to select modules.

After you added the module click Apply.



Completing the Blinky Project

1. Modify the user_board.h*file to include the following lines.

#define BOARD OSCO HZ 12000000
#define BOARD OSCO STARTUP US 50000
#define BOARD OSCO IS XTAL true

#define BLINK_LED AVR32_PIN_PD30

*use the search solution explorer to go to file.




2. Modify the board_init() function in the init.c file in the
user _board folder as follows:

void board_init (void)

{

loport_init(); // This must be called before any other ioport
function

ioport_set_pin_dir (BLINK _LED, IOPORT_DIR_OUTPUT);
//make pin an output

}

The code initialize the I/O port. The LED is connected to the
PD30 pin.




3. Modify the main.c file as follows:

#include <asf.h>
int main (void)

{

sysclk_init();
board_init();

while (true)

{
ioport_toggle pin_level (BLINK_LED);
delay _ms(500);

}

e An LED in series with a 470 ohms resistor connected to the

PD30 and to GND on the other end.



Using the Bootloader on the Mini Board

« Some of us we don't have any JTAGICE debug tool for program
flashing to AVR32 Mini board. Luckily, all AVR32 has
preprogrammed bootloader. Immediately after reset, the
bootloader checks an I/O pin. Usually the 1/O pin is connected
to 1 switch, push button or jumper pin. If the button is pressed,
then the bootloader will enter to load the program from the USB
port.

 We need a program from PC to download the program to the
AVR32. This is called the batchsip.exe program. It is part of
the FLIP v3.4.7 programmer. It can be downloaded from this
link.

* https://www.microchip.com/en-us/development-tool/flip




Create a new device description file

NTOrtunNnalte Ne |3 > ON 4 0O NS N QO

We need
to create a device description file for AT32UC3C264C.

* |nstruction to add AT32UC3C264C part description file.

* 1. From the <Flip install path>\bin\PartDescriptionFiles
folder, copy the file_ AT32UC3C2128C.xml file to your desktop.
Rename the file to AT32UC3C264C.xml.

« 2. Using a text editor, edit the file. Change the Part Name from
"AT32UC3C2128C" to "AT32UC3C264C".

« 3. Change FLASH size from “131072" to “65536".
4. Change INT _RAM size form “32768" to “16384".

e 5. After saving, copy the file back to the <Flip install
path>\bin\PartDescriptionFiles folder.




AT32UC3C264C.xml view

<?xml version="1.8"23
< IDDCTYPE Rttt ennant, did™ >
cPart MAME="AT32UC3C264L" >

<USE PID VALUE="2FEB" /[

«Memory MAME="FLASH"| SIZE="65536" ADDR="328088088" [
<Memory NAME="BOOTLDADER" SIZE="3" INDEX="3"/>
<Memory NAME="SIGNATURE" SIZE="4" INDEX="&"/*
«Memory MWAME="SECURITY" SIZE="1" f>

«Memory MAME="CONFIGURATION" SIZE="32" />

n n
<Memory NAME="USER"™ SIZE="512" ADDR="2@200898" INDEX="11" /> ° Modlfled

«Memory MAME="INT_RAM"| SIZE="16384"| ADDR="8" INDEX="28" />

<Memory MAME="EXT_MEM_ (58" SIZE="8" ADDR="Coasdoad"” [

<Memory MAME="EXT_MEM_CS51" SIZE="8" ADDR="Do2oasas" [

<Memory MAME="EXT_MEM_CS2" SIZE="8" ADDR="CZ000088" [>

<Memory MAME="EXT_MEM (53" SIZE="8" ADDR="CCosooad"” [

<Memory MAME="EXT_MEM DF" SIZE="82E8683" ADDR="8" INDEX="38" />
<Protocol FILE="USBE DFU @2Z.xml" [>

«Protocol FILE="RS5232_TIa3.xml" />
«/Part>



File name reference .xml

Part Name FLASH size INT_RAM
(bytes in binary)

AT32UC3C264C 65536 16384
AT32UC3C2128C 131072 32768
AT32UC3C2512C 524288 65536




Create External Tools menu

« Before using batchisp, it will easier to add it to the external
tools menu. From the menu, select Tools > External Tools.
Press the Add button and edit the following boxes:

Title: DFU AT32UC3C264C

Command: C:\Program Files (x86)\Atmel\Flip
3.4.7\bin\batchisp.exe

Arguments: -device AT32UC3C264C -hardware usb -operation
onfail abort memory FLASH erase F loadbuffer

$(TargetName).elf program start reset 0

Initial directory: $(TargetDir)




External tools View

External Tools o s

Menu contents

OFU ATIZ2UCIADS12
DFU AT32UCIC264C

Title: DFU AT 32003 00

Lormmand: iles (kA6 Atmel\Flip 34. T\bin\batchisp.exe

Arguments: fer 3(TargetMame).elf program start reset 0 L

Imitial directon: ${TargetDir)

v Lse Quiput window Prompt for arguments

Treat output as Unicode

Cancel



We are now ready to download

2. Press the LOAD button and momentarily press the RESET
button. After you hear a beep on your PC, you may now
release the load button.

3. Check if the device Microchip Tools > AT32UC3C appears
In the device manager.

° W ' Microchip Tools

§ AT32UC3C

* 4. From the menu, select Tools> DFU AT32UC3C264C. This
should initiate downloading to the mini board.



Installing DFU usb

If the program did not proceed.

Go to Device manager > Microchip Tools> AT32UC3C (Right-
Click update driver)

Select “Browse my computer for drivers”

Click “Let me pick from a list of available drivers on my
computer”

Click “Have a Disk...”

Click “Browse...”

Find the location >  Program Files (x86)\Atmel\Flip 3.4.7\usb
Select the “atmel _usb dfu.inf” and click Open and OK.

Click “ Next” and wait until the driver successfully installed.


file:///C:/

Board view
;ﬁﬁﬂﬁ“ﬁﬂﬂ¢_,
+ Il” ﬂﬂﬂﬂﬂ 4 L4

=y



Successfully uploaded

Output

Show output from: DFU AT32UC3264C
Running batchisp 1.2.5 on Fri Oct 838 18:46:11 2821

AT320C3C2128C - USBE - USB/DFU

Device selection

Hardware selection

Opening port

Reading Bootloader wversion

Selecting FLASH

Erasing

Parsing ELF file LED_BLINKING.elf
Programming memory

WARNING: The user program and the bootloader overlap!
Programming memory Bxa8888 axB2577
Starting Application RESET 8

Summary: Total 9 Passed 9 Failed @




* Watch Demo video Blinking
* Watch Demo video Multiple LED



Troubleshoot

* Output error after the external tools applied:
e Opening port........ FAIL Could not open USB device.

e |f AtLibUsbDfu not found / ISP done.

e Solution:

1. Go to Tools > External tools ... > Arguments
» - device (Must be the same device)...
e 2. Press the Load and Reset button on board and release.

 The Microchip Tools > AT32UC3C should appear on the device
manager.

 Now try it again. It will work!



Multiple LEDs




The code

e user board.h

#define LED1 AVR32 PIN PC15
#define LED2 AVR32_PIN_PC16
#define LED3 AVR32_PIN_PC17
#define LED4 AVR32 PIN PC18

#define LEDS AVR32 PIN PC19
#define LED6 AVR32 PIN PC28@
#define LED7 AVR32 PIN PC21
#define LEDS AVR32 PIN PC22




e |Inif.c

The code

ioport init();

ioport set pin dir(LEDI1,
ioport set pin dir(LED2,
ioport set pin dir(LED3,
ioport set pin dir(LED4,
ioport set pin dir(LED5,
ioport set pin dir(LEDG,
ioport set pin dir(LED7,

t pin dir(LEDS,

10 por t_'-1

IOPORT DIR _OUTPUT);
IOPORT_DIR_OUTPUT);
IOPORT DIR OUTPUT);
IOPORT DIR QUTPUT);
IOPORT DIR_OUTPUT);
IOPORT DIR OUTPUT);
IOPORT DIR QUTPUT);
IOPORT DIR _OUTPUT);




The code

°* Main.c

while(true){

int t = l@a;
ioport_toggle_pin_level(LED1);
delay ms(t);

ioport_toggle pin_level(LED2);
delay ms(t);

ioport_toggle pin_level(LED3);
delay ms(t);
ioport_toggle pin level(LED4);
delay ms(t);
ioport_toggle pin level(LEDS);
delay ms(t);
ioport_toggle pin level(LEDG);
delay ms(t);
ioport_toggle pin level(LED7);
delay ms(t);
ioport_toggle pin level(LEDS);
delay ms(t); |




-

SWITCHING
BUTTON




Create new project

 Name: SWITCHING_BUTTON

e user board.h
#define BOARD_OSCO0_HZ 12000000
#define BOARD_OSCO_STARTUP_US 50000
#define BOARD_OSCO0_IS_XTAL true

#define MY_LED AVR32_PIN_PD30
#define MY_BUTTON AVR32_PIN_PCO02




The code

//ioport_set pin_mode(MY_BUTTON,
IOPORT_MODE_PULLUP);




The main (latching switch)

board init();

int LEDstate = @;
while(1}{

bool value;

value = ioport get pin lewvel(MY BUTTON);

case @:
ioport s
LED=ta
break;
case 1:
ioport s - _LED,LOW);
LED=ta
break;




The main (Push button)

/* Switch/Push button*/

if(value == 1){ //using button if the value of pin is on a high-state/pulled-up, led is off
ioport set pin lewvel(MY LED,LOW);

1

J

else if(value == 8)}{// while button is pressed, led is on
ioport _set pin level(MY LED,HIGH);




 \Watch Demo video Push switch
* And Latching switch



FILES LOCATION




Uc3c2128c.h location

. #define AVR32 PIN_PAOQO ... PD30



ioport.h location and descriptions

« "\param pin IOPORT pin to configure
e "\param dir Direction to set for the specified pin

» joport_set pin_dir(ioport_pin_t pin, enum ioport_direction dir);

« *\ brief Toggle the value of an IOPORT pin, which has
previously configured as an output.

« "\param pin IOPORT pin to toggle
* joport toggle pin_level(ioport pin_t pin);

» Select the function, right-click Goto Implementation
(Alt+G);




Common IOPORT service main header file for AVR, UC3 and

ARM architectures (Basics)

« |OPORT _DIR_INPUT *\'input pin direction

« |OPORT _DIR_OUTPUT *\ output pin direction

« |OPORT_PIN_LEVEL LOW *\ pin value low
 |OPORT_PIN_LEVEL_HIGH *\pin value high

« ioport_init(); *\ initialize the IOPORT service, ready for use.

* *\ This function must be called before using any other functions in the IOPORT
service.

« joport_enable pin(ioport_pin_t pin); *\ Enable an IOPORT pin

e joport_enable port(ioport_port_t port, ioport_port_mask_t mask); *\param mask Mask
of pins within the port to enable

* joport_disable pin(ioport_pin_t pin); *\ Disable IOPORT pin

» joport_disable port(ioport_port t port, ioport_port mask_t mask); *\param mask Pin
mask of pins to disable



Common IOPORT service main header file for AVR, UC3 and

ARM architectures (Basics)

* joport_set port_mode (ioport_port_t port, ioport_port mask_t mask, ioport_ mode t
mode); *\Set multiple pin modes in a single IOPORT, such as pull-up, pull-down, etc.
config;param mode Mode masks to configure for the specified pin

e joport_set pin_mode (ioport_pin_t pin, ioport_ mode_t mode); *\Set pin mode for one
single IOPORT pin;

* ioport_reset port_mode(ioport_port_t port, ioport port mask_t mask); *\ Reset
multiple pin modes in a specified IOPORT port to defaults; param Mask of pins
whose mode configuration is to be reset.

e ioport_reset pin_mode(ioport_pin_t pin); *\ Reset pin mode configuration for a single
|IOPORT pin; pin to configure

* joport_set port_dir(ioport_port_t port, ioport_port_mask t mask, enum
ioport_direction dir); *\ Set I/O direction for a group of pins in a single IOPORT.

e joport_set pin_dir***

« joport_set pin_level(ioport_pin_t pin, bool level); *\ Set an IOPORT pin to a specified
logical value.



Common IOPORT service main header file for AVR, UC3 and

ARM architectures (Basics)

« joport_set port_level(ioport_port_t port, ioport_port mask_t mask, enum ioport_value
level); *\ Set a group of IOPORT pins in a single port to a specified logical value

* ioport_get pin_level(ioport_pin_t pin); *\Get current value of an IOPORT pin, which
has been configured as an input

» joport_get port level(ioport_pin_t port, ioport_port mask_t masl); *\Get current value
of several IOPORT pins in a single port, which have been configured as an inputs.

* joport _toggle pin_level***

e joport_toggle port level(ioport port t port, ioport_port mask t mask); *\Toggle the
values of serveral IOPORT pins located in a single port.

* joport_set pin_sense mode(ioport_pin_t pin, enum ioport_sense pin_sense); "\Set
the pin sense mode of a single IOPORT pin;param pin_sense Edge to sense for the
pin

« joport_set port sense_mode(ioport_port_t port, ioport_port_ mask_t mask, enum
ioport_sense pin_sense); *\ Set the pin sense mode of a multiple IOPORT pins on a
single port



Common IOPORT service main header file for AVR, UC3 and

ARM architectures (Basics)

iloport_pin_to_port_id(ioport_pint_t pin); *\Convert a pin ID into a its po ;param pin
|IOPORT pin ID to cenvert; retval Port ID for the given pin ID

e joport_pin_to _mask(ioport_pin_t pin); *\Convert a pin ID into a bitmask mask for the
given pin on its port; param pin IOPORT pin ID to convert;retval Bitmask with a bit set

that corresponds to the given pin ID in its port.



Common IOPORT service main header file for AVR, UC3 and

ARM architectures (Basics)

elne_ . .-.- » A -‘-.- A

» #define MY_BUTTON IOPORT_CREATE_PIN(PORTA,6)

Go to
SWITCHING_BUTTON

e ioport_init(); Project

e joport_set pin_dir(MY_LED, IOPORT_DIR_OUTPUT);
* ioport_set pin_dir(MY_BUTTON, IOPORT_DIR_INPUT);
e joport_set pin_mode(MY_BUTTON, IOPORT_MODE_PULLUP);

 Bool value;
« Value = ioport_get_pin_level(MY_BUTTON);
* joport_set pin_level(MY_LED, value);



Reference

A very big Thank you! To motion55 @elab.ph
forum for the “The AVR32 Tutorial”.

* Product page: https://www.e-
gizmo.net/oc/index.php?
route=product/product&search=AT32&product |
d=1418
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