ESP8266 (ESP-07/ESP-12E)
WiFi Shield (=x <

Technical Manual Rev 1r0

A

Gizmo

ESP-07 and ESP-12 WiFi shield is a Wi-Fi Network solution, it can be used to host
the application or connected from another application processor. It served as a Wi-Fi
Adapter, wireless internet access can be added to any microcontroller based designed
with simple connectivity (SPI/SDIO or 12C/UART interface). Applications are Home
Automation, Monitoring Room temperature, Sending/Receiving Data though IOT etc.

Features: General Specifications:

- 802.11 b/g/n Input Voltage: +5vDC [Internal Source]

- Low power 32-bit MCU +7V to 9VDC [External Source]

-10-bit ADC ESP8266 Module Supply: +3.3vDC

- TCP/IP protocol stack Type of ESP: ESP-07 or ESP-12E (Optional)

- Supports antenna diversity Model Vendors: AI-THINKER,DOIT,Espressif

- Wi-Fi 2.4GHz, support WPA/WPA2 Regulator Used: AMS2950

- Supports STA/AP/STA+AP operation modes. On-board IC: 74LVT125

- Support Smart Link Function for both Operating Temperature: -40C~125C
Android and iOS devices. Output Power: +20dBm in 802.11b mode

-SDIO 2.0, (H) SPI,UART, 12C,PWM,GPIO PCB Dimensions: 52.5mm x 53.5mm

- Arduino Compatible
For more info read the ESP-07/12 Datasheet

Note: The ESP-07 or 12 Wifi Shield has been
bootloaded of firmware were you can see on
this manual. It is ***Compatible in Gizduino
PLUS  (with  64KB  Flash  memory)
recommended to use. Arduino IDE 1.8.3 with
Gizduino Patch.

Use this At Your Own Risk!.
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Major Parts Presentation ((:%} Eme

Arduino Compatible Shield

i aﬁ_-Gmizmo ESP-12E Wifi Shield

SUART: K1 (D3),K2 (D2)
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Figure 1: ESP-07 WiFi Shield
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Figure 2: ESP-12 WiFi Shield
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Pin and Module Descriptions @"
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Figure 3: ESP-07 Module Pinouts Figure 4: ESP-12 Module Pinouts
For more information:
Table1.

See the ESP12E Specs/ Datasheet

FOR ESP-07 ADDITIONAL PINOUTS

Pin Functions
RST

ADC
EN
GPI1O16
GPI1O14
GP1012
GPI1O13
VCC
TXDo
RXDo
GPIO5
GP104
GPI100
GP102
GPIO15
GND

Descriptions

Reset the module

[Note: If ESP-07 Module

resets the firmware will erase]

Ao/Analog to Digital Converter or ADC

Enable pin

General Purpose I/O pin 16

General Purpose I/O pin 14

General Purpose I/O pin 12

General Purpose 1/O pin 13

Input Supply 3.3VDC Required, use AMS2950 Regulator
Transmitter, it needs voltage level translator 5VTTL to 3.3V
Receiver

General Purpose 1/O pin 5

General Purpose 1/O pin 4

Bootload mode, Connect it to the Ground to Bootloa
General Purpose I/O pin 2, BUILTIN _LED

General Purpose I/O pin 15,Connect it to the Ground to Bootload
Ground oV

FOR ESP-12 ADDITIONAL PINOUTS

SCLK
MOSI
GPIO10
GPI1O9
MISO
CSo

Clock

Main Output Slave input
General Purpose I/O pin 10
General Purpose 1/O pin 9
Slave output Main input
Chip selection
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Updating ESP-07's Firmware

You may skip this tutorial! (Default firmware when purchased

Download the Followinf Files and Extract them:
1.) esp_iot_sdk v1.5.0_15_11_27.zip from Espressif site
[http://bbs.espressif.com/download/file.php?id=989]
2.) FLASH_DOWNLOAD TOOLS v2.4 150924.rar
from Espressif site
[http://bbs.espressif.com/download/file.php?id=856]

Materials:
1pc -USB to UART Converter Type A to B 1.8m

4pcs - 1pin Wire connector (Female-Male)

1pc -USB Cable or Printer Cable

\ ' -

Construct this Wiring Diagram:

- go to Connect the ESP wifi shield to gizDuino)

IMPORTANT!!!

SWITCH THE ESP MODULE IN FLASHING MODE!!!

L]

FLASHING MODE

Sw3
MODE

Connect GPIO o pin to Ground.
Switch SW3 for flashing mode.

For Correct wiring and flashing mode.

When you connect the USB-UART converter to PC.
"Look if the BLUE LED indicator of ESP-07 Module
will blink once"

it indicates that your connection is correct and its
ready for downloading the firmware

from esp flash tool.

To PCusing
USB - UART connections to ESP-07 Wifi Shield USB Cable
+5V RED wire to +5V TypeA-B
GND BLACK wire to Ground
RXD ORANGE wire to Digital pin 2
TXD BLUE wire to Digital pin 3
AREF GRD 13 12
é i\!\!tl:l:ll R
B i il G|zmo ESP-12E Wifi Shield
J7 3 5
: O
_m 5 7 ’
GO GPIGID VIN HD GPION AV E ; 2
% H 1
@)
QOOQQO =
o
BLUE LED E cocoom
Indicator O O

Figure 5: The connections
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Updating ESP-07's Firmware using ESP Download Tool v 2.4 @

Follow these steps to flash the new firmware [ 53 cAUsess \Desktop\NEW ESP\FLASH DOWNLOAD.. — O X
to the ESP-07 Module.

1.) Close the Arduino IDE if still Opened.
2.) Launch the ESP flash download tool
"ESP_DOWNLOAD_TOOL_2.4.exe" you have
previously extracted.
3.) Apply the following settings
4.) Bin files from the "esp_iot_sdk extracted zip file):
A.) bin\at\noboot\eagle.flash.bin - 0xo0000
B.) bin\at\noboot\eagle.irontext.bin - 0x40000
C.) bin\blank.bin - oxfeooo
D.) bin\blank.bin - 0x7e000

5.) Flash size: 26 MHz

6.) COM port: Choose your COM port number

(note: change the COM from 2 to 4,
nearest the better communication).

7.) Baudrate: 115200 or 345600 (this is not related to

the ESP baud rate) or in my example i used 57600.

Download Panel 1

STOP

&7 ESP F : 3 TC In Download Panel 1, if "FINISH".
Press the STOP button and close the Flashing tool.

FlashDownload ‘ RF InitConfig ] MultiDownload I
Download Path Config

W [_sdk v150\bin\at\noboot\eagleflash.bin .. | ;opp | OxD000D
© [Si50bmetnobestesgieiombtetbin . | sopn 640000
¥ SN NEplel RS0\ BBEREENl . | sopn [NE000
vV SN Epietsdk VIS oBimBlankBin .. | sppr | DRIS000N
o = —
| 2} ADDR 1 :
LN ~ | ADDR

L _] ADDR

SPI FLASH CONFIG

CrystalFreq : M RSt [ SpiAutoset
[26M  +| _ [~ DoNotChgBin
— Default " 4Mbit

- -

" 2ZMbit (One
SPI SPEED SPI MODE = . :
(v 8Mbit DETECTED INFO
* A0MHz « Qlo  16Mbit flash vendor
- : EOh : N/A
¢ 26MHz || € QOUT 1| ~ 3Mbit || fiash deviD:
" 20MHz " DIO  16Mbit-C1 | | 4014h
F e QUAD;:8Mbit
BOMHz pouT  32Mbit-C1 || crystal
26 Mhz

Dom_'r_lnad I_=_'a__nel 1

MAC Address
START Y MAF. SE.CF.TE.DO. R F

AP MAC: 5E-CF-7F-D9-2B-60 ~

STA MAC: 5C-CF-7F-D9-2B-60
STOP

COMPORT: [coms ] BAUDRATE: [57s00 ]

Now press the "START" button and wait for the flashing
process to complete.
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Test connectivity and set the default UART speed

Verifying the firmware using Serial Monitor

Before proceeding it is better to verify that new firmware
is working fine.

1.) Unplug the USB -UART converter from the PC.

2.) Switch SW3 to unflashing mode or remove
GPIO o from the GND.

3.) Then Plug the UART converter to the PC..

For Correct wiring: "Look again if the BLUE LED indicator
of ESP-07 module will blink twice"
it indicates that the connection is successful.

Open the Arduino IDE, select the correct COM port and
open the Serial Monitor [Press Ctrl+ Shift +M].
(The correct settings for the ESP firmware v1.5)

SET Baudrate Speed: 115200
Line ending: Both NL & CR.

Test connectivity with 'AT' and 'AT+GMR' commands.
To set the correct baud rate use this command:
AT+UART_DEF=9600,8,1,0,0

Now set the Serial Monitor speed to 9600 and
test again the communication.

|| coms

AT

CK

AT+GMR

AT wersion:0.51.0.0(Nov 27 2015 13:37:21)
SDK version:1.5.0

compile time:Nov 27 2015 13:57:56

CK

AT+UART DEF=9600,8,1,0,0

CKp

Caution: Do not send AT+RESET or AT+RST. The firmware
will be set to default bin.

Download the "WiFiEsp" library

Direct link here:
[https://github.com/bportaluri/WiFiEsp/archive/master.zip]

Compatible using Arduino IDE 1.8.x and up. I'm using the
1.8.3 for this example.

To add the library:

Go to My Document>Arduinoslibraries> (Paste it)

[Make sure the Folder named "WiFiEsp" contains with the

files inside, it must be extracted not compressed when
adding a library and Restart IDE]

Connect the ESP-07 WiFi Shield to gizDuino.

***GizDuino PLUS with ATMEA644P
Recommended to use.

Download the Arduino IDE 1.8.3 with gizDuino

Patch (Board lists).

Download link for Arduino IDE 1.8.3.
[https://github.com/e-Gizmo/Arduino-1.8.3-IDE-
Windows/archive/master.zip]

After downloading the IDE.

if you are using the gizduino boards

Install first the Prolific driver.
[https://github.com/e-Gizmo/Arduino-1.0.6-1DE-

Windows/blob/master/drivers/Prolific%20USB%20Drivers/P
L2303_Prolific_DriverInstaller_v1.10.0.exeraw=true]
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Uploading the Sample program from WiFiEsp library @ TREme

OPEN the Arduino IDE 1.8.3
Before opening the Arduino IDE, make sure you add the You need a WiFi Network connections
WIiFiEsp library. (WLAN router, Hotspots for Wifi connectivity)

Now Open the WiFiEsp > WebServer.
Go to File>Example> WiFiEsp> WebServer.ino

char ssid[] = "Twim™;
pass[]l = *12345678";

int status = WL_IDLE STAIUS;
int reqCount = 0;

@ sketch_dec22a | Arduino 1.8.3 - O X
File Edit Sketch Tools Help o WiFiBspServer server(80):
ew S N So’ft:e i >
EW, ral
Open.. Curl+0 oy ) Set your network here:
nevwire
;thim:‘ | opendLc ) - char ssid[]=" YOUR_SSID"
=hheg i PCASESS ] char pass[] ="SSID PASSWORD"

Examples i -
PID }

Close Crd+W ) 8 . . .

Save Cties ey Check also the port forwarding: if it is 80,8080, if necessary.

. amcsesst ? o

SaveAs..  CulsShiftes _ WiFiEspServer server(80);
RadioHead b

Page Setup  Ctri+Shift+P RogueSD ’

pt Eh SiE i Select the board:

Preferences  Ctrd+Comma S : Tools> Board:> GizDuino+ w/ ATmega644

| SDplus 4 S

Quit Ctri+Q : SerialGraphiclCD > Gizduino AVR Boards
Sers ? Gizduino X (ATmega1281)
SIME00 Cd 2 =
o i Gizduino+ w/ ATmegabd4
SoftwareSenvo ¥ Gizduino [0T-644
SPEDS5408 5 Gizduino+ w/ ATmega324
SPi > = Gizduino+ w/ ATmegal64
SWTFT-Shield > - Gizduino (mini) w/ ATmega328
talkie 2 Gizduine (mini) w/ ATmegal68
ATy | SunipctiEA Gizduino (mini) w/ ATmega88 (16 MHz)
TEE_ESP_WIFI H ScanNetworks Gizdui . AT 8 (8 M
TimerOne ~' UdpNTPClient EHRNG (s wic A Tmege § )
ToiichStinen | UdpSendReceive Gizduino miniUSB w/ ATmega328
Usglib 1 WebClient Gizduino minilU5B w/ ATmegal68
USB_Host_Shield WebClientRepeating Gizduino+ (mini) w/ ATmegabdd (Sangu|
UTFT 1 WebClientsSL Gizduino+ (mini) w/ ATmega324 (Sangu |
VoiceRecogrition?3 NN Gizduino+ (mini) w/ ATmegal64 (Sangu|
WehServer 3 WebServerAP '
WiFi i WebServerled Select the COM Port Number: { Serial ports

|
WiFiEsp i test ’ Tools>Port> COM12 COM1
¥ comnz
Change the Serial connection to Now Click Upload.

Digital Pin 2 and Digital Pin 3

#include "WiFiEap.h"

// Emulate Seriall on pins &/7 if not pressnt
HAVE_HWSERIALL

e "SoftwareSerial.h”
SoftwareSerial Seriall{2, 3); // RY, TX

F¥endit
1
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Serial Monitor and Web page output

Sample Attempting
to connnect to WPA SSID:

Note: This is an example Output
from the Serial Monitor:

Get the IP address and
Open browser type:
192.168.0.112 or the given IP address

It will display the message:
Hello World!

and Requests received and Analogouput

Page refresh every 20 secs.

192.168.0.112

€9 comz2

[WiFiEap] Initializing ESP module
[RiFiEsp] >>> TIMEOUT >>>
[WiFiEsp] Canmot initialize ESF module

[WiFiEap] Conmected to meow
You're connected to the network
SSID: meow

IP hddress: 192.168.43.207

[WiFiEsp] Server started on port 20
[WiFiEsp] New client O
ew client
F[T / HITB/1.1
Host: 192.168.43.207

Connection: keep-alive
Upgrade-Insecure-Requests: 1

iAccept-Encoding: gzip, deflate, sdch

Sending response

[WiFiEsp] Disconmecting 0
IClient disconnected
[WiFiEap] New client 1
Fleu client

<

[ Autoscroll

rtempting to connect to WEBA SSID: meow

(Accept-Language: en-US,en;g=0.8,I{il;g=0.¢

Both NL & CR

iTo see this page in action, open a browser to http://192.168.43.207

User-Agent: Mozilla/5.0 (Linux; Android €.0.1; ASUS ZOOED Build/MMB29F)
Accept: text/html,application/xhtml+xml,applicaction/xml;g=0.9,image/wek

>

115200 baud Clear output

3 R

Hello World!

€5 coms

Requests received: 6
Analog input AQ: 336

Rccept:

Sending response

[WiFiEsp] Disconnecting 0
IClient disconnected
[WiFiEsp] New client 0
New client

IGET / HITE/1.1

Host: 192.168.0.112
User-Agent: Mozilla,/5.0 (Windows NI 10.0;
text/html, application/xhtml+xml, application/xml ;g=0
Lccept-Language: en-US,en;g=0.5
2ccept—Encoding: gzip, deflate
IConnection: keep-alive
Upgrade-Insecure-Requests: 1
iCache-Control: max-age=0

Sending reaponse
[WiFiEsp] Disconnecting 0
iIClient disconnected

rv:30.0) Gecko/20

<

>

Autoscroll

[BothmL&cr | [115200 baud ~ |
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Schematic Diagram @ SiEteme
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PCB Layout Guide @ e-Gizmo
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