GIZDUINO V4.0

Technical Manual Rev 1r1
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GIZDUINO V4.0 ATMEGA168/328

The Gizduino v4.0 is the improved version of the e-
Gizmo Gizduino microcontroller boards. Similar to
the previous version, it has 14 digital /O pins and 6
analog programmable inputs pins, an on-board 16
MHz crystal oscillator, DC power jack, ICSP header,
reset button, USB connection. One of its additional
features is the RX-EN rocker switch that promotes
hassle-free programming when dealing with serial
communication to avoid the common "not in sync"
problem upon uploading. Unlike the other versions,
the v4.0 doesn't need to be shorted for external or
internal supply input.

The Gizduino microcontroller board can be easily
used for prototyping, research, thesis, and a lot
more. It is open source thus makes coding and
interfacing easier since libraries are available for
download on the net for user's convenience. The

microcontroller board is very flexible in terms of
applications especially in sensors, serial devices,
and alike. It is compatible for almost all platforms
such as Windows XP, Vista, 7 and 8, Mac OSX,
and Linux.

It also has its available add-ons that are so-called
"shields" that makes prototyping easier. Some
shields available are the GSM shield, GPS shield,
Motor Driver shield, and a lot more.

Features and Specifications

- Microcontroller: ATMegal68/328

- User interface: USB Port, DC Jack, Reset,
Serial enable switch

- Debugger port: ICSP port

- Power input: 8-12V Max, 5V USB

- Crystal oscillator: 16MHz

- Reqd driver: Prolific USB Serial Driver 2009
and above
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MAJOR COMPONENTS PRESENTATION
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Figure 1. Gizduino 168/328 Major Parts Presentation

Component specifications:

U1 - ATMEGA168/328 Microprocessor chip
U2 - On-board 5V Voltage Regulator
U3 - PL-2303 USB to RS232 Bridge Controller
Y1 - 16MHz crystal oscillator

ATMEGA Chip Comparison

ATMEGA 168

16KB (Flash memory), 512 bytes EEPROM, 1KB RAM
ATMEGA 328

32KB (Flash memory), 1KB EEPROM, 1KB RAM
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PARTS & PIN DESCRIPTIONS
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Table 1. JP3, JP4, Digital I/O Pin assignments

No. L.D. Description
1 AREF Analog Reference
2 GND Ground
3 13 Digital I/O (SCK)
4 12 Digital I/O (MISO)
5 11 Digital I/O (PWM/MOSI)
6 10 Digital 1/0 (PWM)
7 9 Digital 1/O (PWM)
8 8 Digital I/O
9 7 Digital I/O
10 6 Digital I/O (PWM)
11 5 Digital 1/0 (PWM)
12 4 Digital I/O
13 3 Digital I/O (PWM)
14 2 Digital I/O
15 1 Digital 1/O (TX)
16 0 Digital I/O (RX)

Table 2. JP2 Analog I/O Pin assignments

No. L.D. Description

1 AO Analog I/0 or Digital I/O

2 Al Analog I/0 or Digital I/O

3 A2 Analog I/0 or Digital I/O

4 A3 Analog I/0 or Digital I/O

5 A4 Analog I/O (SDA) or Digital I/O
6 A5 Analog I/O (SCL) or Digital I/O
7 A6 Analog 1/0

8 A7 Analog 1/0

Table 3. JP1 Power Pin assignments

No. 1.D. Description
1 Reset Reset
2 +3.3V 3.3VDC Device Power supply
3 +5V 5VDC Device Power supply
4 GND Ground
5 GND Ground
6 Vin +5V(USB) / Vin(Ext)

Tips and reminders:

For 12C interface, A4 (SDA) and A5 (SCL) can be
used.

Reset can be used externally by adding a two pin
tact switch with one leg of the switch on the reset
pin, and the other one to the ground.

As shown, A6 and A7 cannot be used as digital
pins.

The Gizduino can be powered up by wiring a
positive DC supply on your Vin pin noting that Vin is
limited to 12VDC, and a negative power supply on
the GND pin.

Pin 13 is also the pin used by the data transfer LED
indicator.
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GIZDUINO SET-UP
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In software installation, you need the
CD/DVD from e-Gizmo when you buy one of our
kits. But if you don't have the CD. you can always
download the IDE from the Arduino website just go
to http://arduino.cc/en/Main/Software look for the
latest version of the IDE or visit our Google Drive
cloud storage:

https://docs.google.com/folder/d/0BxdLxDCD6HidO
GpmX21aS3pPWW8/edit?usp=sharing

Part 1: How to install the Arduino Software form
the e-Gizmo DVD?

Step 1: Software installation

1. Insert the CD on your CD-ROM/DVD-R drive
then open the "e-Gizmo KITS" folder

-

—
U@v| J v e-Gizmo DVD »

Organize ¥ [ Open  Includein library v » 55 v M @
fa -
-{ Favorites ) Articles
. Construction KITS
- Libraries | e-Gizmo KITS |
3 Documents = , G840 CD
J‘. Music . Modules and Other Products
=] Pictures , SlimBoard CD
B videos | Softwares

. Thermal Printer CD
1M Computer ) Touch Screen CD
£ Local Disk ( -
£ e-Gizmo KITS Date modified: 29/8/2013 3:06 PM

e | .
QA‘__ File folder

3. Open the "Software" folder.

@uv| €« e-Gizmo KITS » Gizduino »

Organize « Include in library « Share with » = Bz - [ l@l
A Favanics Name Date modifie *
J GizduineX 29/8/2013 34
4 Libraries . minilSB 29/8/2013 34
% Documents|z| | i Software 29/8/2013 34|
| 8/ J
& Music v 29/8/2013 3.ti=
=] Pictures '@ Gizduino manual.pdf 16/12/2011 6|~
B videos ] gizDuinolnstallationGuide.pdf 19/6/2012 3:|

|
12/9/2012 34—
12/9/2012 3:

'@ Parts Placement.pdf

1M Computer L PCB Bottom Layer.pdf

& Local Disk { ~ « | [ ] s

14 items

2. Find the "Gizduino" folder then open it.

-

@l\._./l'| . v e-Gizmo DVD » e-Gizmo KITS »

Organize v Include in library Share with +  » =~ A @
. -~
[ Favorites Name
, ePICPRO

4 Libraries . EZ HMI display terminal

3 Documents = | Gizduino 3

&' Music | GPS Module (Shield)

=] Pictures J GPS5 Shield 2

E Videos . GSM-GPRS (Shield)

. G5M-GPRS Modem

18 Computer | Gyroscope Module

d

4.Unzip Arduino-1.0.5-windows (winZiip/WinRAR)
if you are using WindowsXP,7,8 or Arduino-1.0.5-
macosx (WinZip/WinRAR).

& =[) « cad.. » soft.. » -]

E._ Open with WinZip =  »

Organize «

- Favorites hame

. Patch Files to Add gizDuine in Arduine IDE Board List Menu_files
arduine-1.0.5-linw32.tgz
arduine-1.0.5-linuxb4.tgz

arduine-1.0.5-macosx.zip

4 Libraries

1M Computer

.. arduino-1.0.5-windows.zip

o o 0

?j MNetwork L giz.[juinopatch.-l.U.S.zip
|| Patch Files to Add gizDuino in Arduino IDE Board List Menu.htm
4| i | b
- arduino-1.0.5-windows.zip Date modified: 8/8/2013 10:46 AM
=i
= WinZip File Size: 97.3 MB
sl "

5. Unzip to.. a different location (e.g C:\Arduino-
1.0.5) or into your computer Desktop or wherever
you are comfortable with.

201 B T [ = | WinZip Pro - arduino-1.0.5-windows.zip = | B S|

Unzip Edit Share

|]— Folder name:

Backup Tools Settings View Help '@'

kt..\Software [Unzip | | Cloud | *

B
o i .
75 Location:

Unzip

[%3 Unzip
[:gé, Unzip To...

Folders in Winz

2 [arduino-1.

. arduino Unzip to a

d
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Step 2: Driver installation

1. Open the "Arduino-1.0.5" folder.

2. Go to "DRIVERS" folder>"PROFILIC DRIVERS"
folder>Double-Click the PL2303_PR.. v1.7.0.exe

to install the driver. You can also download this
driver from the prolific website.

=)
@"\_}'| . <« drivers » Prolific USB Drivers R4 |¢,.| | Search Prol.. 2 |
Organize v Open Share with - Mew folder i= » @ I@
-
< Favorites Name Date modified
| PL2303_DriverInstallerv1.7.0_ReleaseMote.... 1/8/2012 3:43 PM
4 Libraries &2 PL2303_Prolific_DriverInstaller_v1.7.0.exe 1/8/201211:12 AM
&3 PL2303_Prolific_DriverInstaller v10518.exe  23/7/2009 10:52 AM
Lol Computer | releasenote.bd 23/7/200911:16 AM
“! Metwork
< 1 3
23  pL2303_Prolific_DriverInstaller_v1.7.0.exe
*3 Application

After which, it shall direct you to the installation
wizard.

PL-2303 Driver Installer - InstallShield Wizard [

Preparing Setup
Please wait while the InstallShield ‘Wizard prepares the setup.

PL-2303 Driver Installer Setup iz preparing the InstallShield Wizard, which will guide vou through
the rest of the setup process. Please wait.

InstallS hield

Cancel

After the preparing setup you can now install the

PL-2303 driver, continue this by clicking on
<Next>.

‘Welcome to the InstallShicld Wizard far PL-2303
USE-to-5exial

The InztallSkeeld \Wizsid vl s ball PL-2303 USE do-Senial
o youl compuber Tio continug. chok Mest

i pond rean sl i o

PL-2303 LIS |o-5erial iz

Irestadlig
Lo MECCET 3C-0844-80F 3-9571 - DOFTMF CESE Pvis st 20 sps

When the InstallShield Wizard has successfully
installed PL-23023 USB-to-Serial. Click<Finish>
to exit the wizard.

InztallS hield Wizand Complete

The InstalGheld wWizad has sucesssfuly nataled FL-Z303
UISE-torSenial Chck Fnish bo et the wazard
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3.After you installed the driver. Connect your
Gizduino to the PC using a USB A-B connector.

‘ANENENEE EENEEEEE
| spmeel ot 4 £
: RN
- - o
pup PHR_SEL Reset 2
8=
= [_D" I - 1csp
§355es , msn
- F8288 M5 Nsss
‘EEEEEE EEEEEE

<hn|] Connect to PC

Then it will appear on your task bar.
(Fig 1 and Fig 2)

Installing device driver software % *
Click here for status.

Fig 1. Shows the installing device driver.

Prolific USB-to-Serial Comm Port (COM18) % X
!'H@' Device driver software installed successfully.

Fig 2. The device driver software installed

successfully.

Note: here you can see the assigned COM port
number.

Step 3: Device/Port Checking
1. Go to the "Device manager". (Fig 3.)

Control Panel>System and Security>System (Click
the "Device Manager")

2. Look for ports(COM & LPT).

3. Get the (COM #). This should be the assigned
port for your arduino (Serial Port).

) Device Manager

File Action View Help
&= | F B HE & B &S
4 5 Roma

> 45 Batteries
-8 Computer
b+ Disk drives

» B, Display adapters
> 85 Human Interface Devices
> -Cg IDE ATA/ATAPI controllers
» 25 Imaging devices
b= Keyboards
> -E5] Memory technology driver
> -l Mice and other pointing devices
> - Monitors
> -8 Network adapters
7% Ports (COM & LPT)
T Prolific USB-to-Serial Comm Port (COMIS)
[0 Processors
>-% Sound,video and game controllers
> {8 System devices.
>-§ Universal Serial Bus controllers

N

Fig 3. the device manager where you can see the
COM number assigned for your Arduino IDE
Serial Port.

Part 2: What's next before | can upload any of
my sketches?

After getting the assigned COM port for your
Gizduino, configure your Arduino IDE using the
following settings:

1. Boards installation

Install the boards on your Arduino IDE by simply
unzipping and copying the patch files from the CD
at e-Gizmo CD\e-Gizmo KITS\Gizduino\Software\
gizDuinoPatch1.0.5-windows.zip

OR, download it from http: /le-
gizmo.blogspot.com/201  3/03/patch-files-to-add-
gizduino-in-arduino.html?view=flipcard

then, paste it to your assigned Arduino directory
at Program Files\Arduino\hardware.

(this may differ for Windows 7/Windows 8 users
depending on their OS)

Home Share View
€ (3) v 1l « Program Files (xB6) » Arduino » v & Search Arduino
Marne ‘ Date modified T
J drivers 8/1/2013 1:42 PM Fi
. examples 3 1:48 PM Fi

3 1:51 PM Fi
3 1:49 PM Fi
3 1:49 PM Fi

. hardware

J java

Date created: 8/1/2013 1:48 PM

| Size: 126 MB

¢ | Folders: arduino, gizduino-, tools

. reference

J tools
@ arduino.exe
%] cygiconv-2.dll
%] cygwinl.dil
(%] libusbO.dll
] revisions.tt
%] ndSerial.dll
@ uninstall.exe
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2. Choosing the right board

After installing the boards, open your Arduino
IDE. After which, on the menu bar, go to
Tools>Boards

(Choose the type of board that you are using, just
in case you don't know, you may always check it
out on the board you bought)

e.g Gizduino (mini) w/ ATmega328

Help © | Gizduino (mini) w/ ATmega328
Auto Format Ctrl+T Gizduine (mini) wy/ ATrmegal6s
Archive Sketch Gizduine (mini) w/ ATmegal8 (16 MHz)
Fix Enceding & Reload Gizduine (mini) w/ ATmegad (8 MHz)
Serial Monitor Ctrl+Shift+M ATMEGAS Experimenter Board
Gizduine miniUSB w/ ATmega328
Board »
E Gizduine miniUSB w/ ATmegal68
Serial Port 4
Gizduine+ (mini) w/ ATmegab44 (Sanguinc mode)
Programmer 4 Gizduine+ (mini) w/ ATmega324 (Sanguino mode)
Burn Bootloader Gizduine+ (mini) w/ ATmegals4 (Sanguino mode)

Fig 3. Check your BOARD.

Note: If you can't see the Gizduino board list. You
may have forgotten to extract the patch files on
your hardware folder.

Il SERIAL PORT

Make sure that you are connected the right Serial
Port COM number.

MENU BAR>TOOLS>SERIAL PORT>

(Choose the assigned COM port on your USB
Cable connections to PC)

Tools| Help
[
| Auto Format Ctrl+T
| Archive Sketch
' Fix Encoding & Reload
Serial Monitor Ctrl+Shift+M
Board k
Serial Port ¥ & | COMIB
Programmer L

Burn Bootloader

Fig 4. Check your COM PORT number.

Page 7 of 7 pages ©2013 by e-Gizmo Mechatonix Central

Gizduino v4.0



-
SKETCH UPLOADING 2@2 G i]:f Zmo

ECHATRONIX CENTRAL

After choosing the right COM port and Board, what is left is how to upload a sketch. For the most
basic example, on your Arduino IDE, click File>Example>1.Basic>Blink. After that, click the upper leftmost
icon (check mark) to VERIFY your sketch. Verifying is only used to check if there are no syntax errors or
issues in your sketch. Next, click the icon with the arrow point to the right, that is your UPLOAD button. It
simply uploads your program to your MCU board. Then, that's it, the data transfer LED indicator should
blink as stated on the description of the sample sketch.

x

(=0} x

File Edit Sketch Tools Help

o warify

Blink
o

o)

File Edit Sketch Tools Help

° Upload

Blink

A ~
Blink
Turns on an LED on for one second, then off for one second, repeatedly.

Blink
Tuzns on an LED on for one second, then off for one second, repeatedly.

This exemple code iz in the public domsin.
i

This example code is in the public domain.
*y

// Pin 13 has en LED connected on nost Arduino boards.
7/ give it a name:
int led = 13:

/¢ Pin 13 has an LED connected on most Arduino boards.
£ give it a name:
int led = 137

// the setup routine runs omce when you press reset:
void setup() {
// initialize the digital pin as an ourput.
pinMode (led, DUTPUT):
i

/4 the setup routine runs once when you press resec:
woid setup() {
#/ initialize the digital pin as an output.
pinMode (led, OUTPOT);
+
// the loop routine rung over and over again forever:

void loop() {
digitalUrite(led, HIGH):; // turn the LED on (HIGH is the voltage lewel)

// the loop routine runs over and over again Eorever:
woid loop() {

:131:511;3;\:%(1&, HIGH) » A4 oturn Eha LED on ‘;HIGH iz the woltage level) e Ly (1000] § T
‘.E ?Yt .J' {4 Meakfor 8 scoon & digitalWrice (1ed, LOW); 4/ turn the LED off by making the wvoltage LOW
digitalWrice(led, LOW): /4 turn the LED off by making the woltage LOU delay(L000) ; 4/ wait for a second

delay(1000) 2 /4 wait for & second

}

}

Gizduing (mini)nd AT

STEP 1: Verify: In this way, the sketch is check for STEP 2: Upload: Sketch is uploaded into your

syntax errors or issues in library, etc. This is MCU board. Unlike other MCUs, the uploaded
optional and you may proceed to uploading sketch can be changed any time as the user
immediately. wishes.

Common issues:

(1) avrdude: Expected signature for ATMEGAXXX (2) avrdude: stk500_getsync(): not in sync:
is XX XX XX. Double check chip, or use -F to resp=0x00 avrdude: stk500 disable(): protocol
override this check. error, expect=0x14, resp=0x51

> |t simply means that you chose the wrong board --> You may try to reconnect your Gizduino to the

on the boards list. Select the correct board and re- ~ USB portand try uploading again..
upload your sketch. --> If you are dealing with Serial interface, make

sure RX is disabled by switching up the RX-EN
switch

For more information of the syntax of the Arduino IDE, you may go to
Help>Reference on you Arduino IDE. These are offline webpages, so you
can view it without an internet connection
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PCB BOARD PRESENTATION
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Figure 3. Gizduino v4.0 Top PCB layout

Figure 4. Gizduino v4.0 Bottom PCB layout

Page 9 of 7 pages

©2013 by e-Gizmo Mechatonix Central

Gizduino v4.0




ONIX CENTRAL
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