ce-zmo  EBOT with EGRA

MECHATRONIX CENTRAL
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VARIANTS:

[ J

[ J

[ J

[ J
Included:

° - PS2 Controller
- USB Cable Type A to mini B
- 9V 1A adaptor

EBOT with EGRA
> with EGRA (Robotic Arm)
> with PS2 Controller




e ’mu‘* EBOT w/ EGRA

VARIANTS:
 EBOT w/EGRA*  -_4x4 entry level mobile robot fused with mini robotic arm our very

own e-Gra. Roving and Pick n' Place functions made more easier.
With PS2 Controller wireless device to control it.




e EBOT w/ EGRA

General Specifications: Features:
* Battery: 7.2V Ni-MH 800mAh rechargeable - Pick N' Place of an object.
* On-board Peripherals: - withPS2 controller wireless
- IC Atmegal68 w/ 16KB Flash memory device to control it,
* Dimensions: 180mm x 138mmx120 mm
with spoiler
* Weight: Approx. 0.9 KG
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e-G|zmo EBOT w/ EGRA

MELHATHUMNIX CENTHAL .
Connections

@B E-GRA (Robotic Arm)
- for Pick N' Place of an objects.

B ——— @@ UHF Standard Receiver Only
o - to controll the arm and motors.
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MECHATROMIX CEMTRAL .
Connections

CJ TUCK
P6: SERVO 4

GRIPPER ()
P3SERVO1 _

LIFT
P5: SERVO 3

BASE
P4: SERVO 2



re-Gizmo UHF Rx

Connections

ATHUMNIX CENTRA

CoNi @ CH SEL P2
SRS (.

e=Gizmo P
UHF-STD Rev 1RO |°
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UHF to P9
Vcc: +5V
GND : GND
TXD : TXD
RXD : RXD



Servo Supply J2

Put a jumper

P

WMd A+ N2
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Softwares and library

documents/ARDUINO IDE SOFTWARES
Download Arduino 1.8.5 egizmo themes new (Windows)
Choose your Arduino IDE for your OS.

v PL2303_Prolific_Driverlnstaller v1.10.0

documents/ARDUINO IDE SOFTWARES
Download Prolific Driver v10.0 (Windows)
(For Mac 0S users) Download md_PL2303_MacOSX

documents/PB0T2018
Download eGizmo_PBO0T2018.zip and eGizmo_PS2Controller
(Unzip this before you move to libraries)

v A =< Arduino > libraries

~ b
Name

AT105

DHT
eGizmo_PBOT2018
Ethernet

SD


http://www.e-gizmo.net/oc/kits
http://www.e-gizmo.net/oc/kits
http://www.e-gizmo.net/oc/kits

Connect the EBOT to PC
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USB Connector

Open Arduino IDE.
USB Cable



Uploading eBot e-Gra.ino

On the Arduino IDE.
1.For EBOT w/ EGRA codes you need PS2 controller
Open the E-BOT_4x4_EGRA_PS2_CONTROLLED.ino
Go to File>Open> E-BOT_4x4_EGRA_PS2_...ino 3. Port select
| | E-BOT 4x4 EGRA PS2 CONTROLLED |+—— Go to Tools>Port>COM#

E-BOT 4x4 GRIPPER_PS2 CONTROLLED geltectDthe_ corr:/rl'ect port
E-BOT 4x4 LINE 0 to Uevice Manager

if you're not sure.
E-BOT_4x4_ MAZE

E-BOT_4x4_SOCCER_BT_CONTROLLED

E-BOT 4x4 SUMO
2. Board select

Go to Tools>Boards>gizDuino (mini) w/ Atmega168

Tips for uploading: =
Press and Hold the SYS RST (SW3)

Tegk et — switch ON the power and
uto Format trl+ .
Archive Sketch ClICk Upload. Release RST
Fix Encoding & Reload
Serial Monitor Ctrl+Shift+M when done.

Serial Plotter Ctrl+5Shift+L

WIiFi101 Firmware Updater

ArduBlock

Board: "Gizduino (mini) w/ ATmega168"
Port
Get Board Info

YIMOd  Tas i 1 Z

—nd L
154 SAS PRI y) 3N 3 1 I8 o

Programmer: "AVRISP mkll”
Burn Bootloader

SYS RST POWER SW



e MECHATRONIX CENTRA

Universal PS2 Controller.

R1 and R2
= Lift up and Down

L1and L2 o

= Gripper Pick or relase \

Buttons [
Up = Forward
LEFT = Turn Left
Right = Turn Right
Down = Reverse

.......
e

)

Shape button
Triangle and Cross
= Tuck up and down
Square and Circle
= Base turn left
And turn right

) Left Joystick
= Motor Controls



SYNTAX
Set motor direction: e

PBOT.DIRECTION(whichmotor,dir);

where:
whichmotor = MOTOR_A or MOTOR_B, MOTOR_BOTH
dir = MOTOR_FWD,MOTOR_REV

Set motor speed:

PBOT.SPEED(whichmotor,speed);

where:
whichmotor = MOTOR_A or MOTOR_B, MOTOR_BOTH
speed = 0to 255, 0 = Full Stop, 80 = Neutral,255 = High, limit 250

EXAMPLES;

PBOT.DIRECTION(MOTOR_BOTH, MOTOR_FWD);
PBOT.SPEED(MOTOR_BOTH, 80);



SYNTAX

PBOT.SERVO(whichSERVO,pulsewidth);
where:
Whichservo =1to 4, ignore other values

Pulsewidth = 0 to 180 (degrees)
- value less than 500 stops the Servo PWM generator

- the pulsewidth converted to degrees from 0 to 180 (default)

EXAMPLES;

PBOT.SERVO(1, 15);
delay(1000);
PBOT.SERVo(1, 90);
delay(1000);



Turn your Ebot Sumo for
More Functions like...

Go to Next Page... [



ce-(GGizmo LINE SENSOR

MECHATRONIX CENTRAL

o 20 LINE CAL - for making line sensor calibrated as easy.
(to calibrate read the page 5)

7 @® LINE SENSORS CONNECTION (P7):

=X L nyy— GND,DRV,LN3,LN2,LN1

| _ ' 7 LINE SENSOR LED INDICATORS:
=" - LN3(D13), LN2(D12),LN1(D11)
- if LED is ON, black color detected
- if LED is OFF, white color detected
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Uploading Linebot.ino

On the Arduino IDE.
1. Line Follower codes
Go to File>Examples>eGizmo_PBOT2018>LINEBOT

¢ eGizmo_PBOT2018 AVOID_COLLISION

EmonLib LINEBOT D
Esp8266EasyloT MAZE

ESP8266wifi MOTOR_TEST

Ethernet SERVO_SWEEP

etherShield SUMO

2. Board select
Go to Tools>Boards>gizDuino (mini) w/ Atmega168

Tools Help
Auto Format Ctr+T
Archive Sketch
Fix Encoding & Reload
Serial Monitor
Serial Plotter

Ctrl+Shift+M
Ctrl+Shift+L

WIiFi101 Firmware Updater
ArduBlock

Board: "Gizduino (mini) w/ ATmega168"
Port
Get Board Info

Programmer: "AVRISP mkll”
Burn Bootloader

3. Port select
Go to Tools>Port>COM#
* Select the correct port
* Go to Device Manager
if you're not sure.

Tips for uploading:

* Press and Hold the SYS RST (SW3)
switch ON the power and

Click Upload. Release RST

when done.

1—>_J9YVH )/ 44

BT LD
| I e -
CMS .

= it
15y SAS = -l N

SYS RST

POWER SW



LINE SENSOR

1. After uploading your code for linesensors.
Turn OFF the POWER switch.

Turn ON the POWER Switch.

Turn HIMOd  TMs 8 Z
Off o T —
i ‘H { Turn On
2. Place the eGizmo PBOT controller to the "black L LB
line" then
A. I
N a LN2 (D12 LED indicator) is ON.

BEBL.ACK

\

TN ZN'I ENT
Press and Hold LINE CAL and SYS RST,

while pressing and holding the buttons,

NN N
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ﬂ "5y SAS (¥ il 1) 3INIT



LINE SENSOR

3. First RELEASE the SYS RST followed by LINE CAL.
Make sure the 3CH Line sensors are faces on the
"black line"

— 81D LTD

4

t EH I ?6-
T 115y SAS (e pat v INI Now Press LINE CAL once

for the black color calibration.

and you will see the LNT and LN3 (T s s T =i

. . . 1rF .| ) ]
(D11 and D13 LED indicators) are i t o 6 <t %'
Turn ON and LNT1 is blinking. 7 e 115y SAS CInEPAR 1y) 3N
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TNT ZN7 N
SR
10 ]




LINE SENSOR

4. Next, if the L3 (D13 LED indicator) is blinking.

\

TNT ZN7 £NT1

g|i| ;i'\ NE After that you will see all the LEDS
RN = for linesensors are ON.

YA

TNT ZNT £NT1

Place the 3CH Line sensors on the "White track".

Ill |l\ S

WA LTTE

9. Now your eGizmo PBOT Controller
Linesensors are calibrated. Then
Press the RESET button or
Switch off and turn ON again.

You can now trace the line and DONE.

Then Press LINE CAL again once for the
white color calibration.
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| "’E“GiZI A
P2 - MECHATRONIX CENTRAL

=)

SYNTAX

* PBOT.LS1_LEFT();
* PBOT.LS2_CENTER();

* PBOT.LS3_RIGHT(); /v
OUTPUT LS1 LS3
* WHITE LINE DETECTED =0 or LOW LS2

* BLACK LINE DETECTED =1 or HIGH

EXAMPLES;

If (PBOT.LS2_CENTER() == HIGH) // if line sensor 2 center is high
{

Serial.println(“Black line detected!”);

}



MOTORS

. @8 MOTOR WIRE CONNECTIONS (P2):
E—ulZmo .
M—BOT CONTRO MOT 1 -1A,1B ; MOT2 - 2A,2B

MOT 1= LEFT -

Blue-Bottom
Yellow-Upper

~I
i
o
.
Loy
s

GND +¥ PWM  GND +V PWM

MOT 2 = RIGHT
Green-Upper

Black-Bottom

*Please don not depends on the color of the wires. -
Follow the location of it.




Uploading Motor Test.ino

On the Arduino IDE.
1. Motor controls codes

Go to File>Examples>eGizmo_PBOT2018>MOTOR_TEST

¢ eGizmo_PBOT2018 AVOID_COLLISION

EmonlLib LINEBOT

Esp8266EasyloT MAZE

ESP8266wifi MOTOR_TEST «—
Ethernet SERVO_SWEEP

etherShield SUMO

2. Board select
Go to Tools>Boards>gizDuino (mini) w/ Atmega168

Tools Help
Auto Format Ctr+T
Archive Sketch
Fix Encoding & Reload
Serial Monitor
Serial Plotter

Ctrl+Shift+M
Ctrl+Shift+L

WIiFi101 Firmware Updater
ArduBlock

Board: "Gizduino (mini) w/ ATmega168"
Port
Get Board Info

Programmer: "AVRISP mkll”
Burn Bootloader

3. Port select
Go to Tools>Port>COM#
* Select the correct port
* Go to Device Manager
if you're not sure.

Tips for uploading:

* Press and Hold the SYS RST (SW3)
switch ON the power and

Click Upload. Release RST

when done.

1—>_J9YVH )/ 44
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SYS RST POWER SW



SYNTAX

Set motor direction: e

* PBOT.DIRECTION(whichmotor,dir);

where;
whichmotor = MOTOR_A or MOTOR_B, MOTOR_BOTH

dir = MOTOR_FWD,MOTOR_REV

Set motor speed:

* PBOT.SPEED(whichmotor,speed);

where:
whichmotor = MOTOR_A or MOTOR_B, MOTOR_BOTH

. speed = 0to 255, 0 = Full Stop, 80 = Neutral,255 = High, limit 250
EXAMPLES;

PBOT.DIRECTION(MOTOR_BOTH, MOTOR_FWD);
PBOT.SPEED(MOTOR_BOTH, 80);



1)

MAZE/SUMO

IR RECEIVERS 38Khz
- U5, U6, U7

{3 IR LED TRASMITTER
- D17, D18, D19
- Distance Range: 2 - 4 inches

IR LED INDICATORS
- COL1(D14), COL2 (D15), COL3 (D1é)
- if LED is ON, Object detected
- if LED is OFF, No object detected

£

K

‘= BOOT<>PU
SWh D18

o



Uploading Maze.ino

On the Arduino IDE.
1. Maze Solver codes

Go to File>Examples>eGizmo_PB0OT2018>MAZE
3. Port select

, eGizmo_PBOT2018 ) AVOID_COLLISION Go to Tools>Port>COM#
EmonLib > LINEBOT * Select the correct port
Esp8266EasyloT 1 Maze — * Go to Device Manager
ESP8266wifi MOTOR_TEST if you're not sure.

Ethernet 1 SERVO_SWEEP
etherShield ' SUMO

2. Board select

Go to Tools>Boards>gizDuino (mini) w/ Atmega168 Tips for uploading:
* Press and Hold the RST (SW3)
prrr— oot switch ON the power and
o e & Reons Click Upload. Release RST
ot o oot when done.

WIiFi101 Firmware Updater
ArduBlock

Board: "Gizduino (mini) w/ ATmega168"
Port
Get Board Info

Programmer: "AVRISP mkll”
Burn Bootloader



Uploading Sumo.ino

On the Arduino IDE.
1. Sumo fighting codes

Go to File>Examples>eGizmo_PB0T2018>SUMO
3. Port select

, eGizmo_PBOT2018 ) AVOID_COLLISION Go to Tools>Port>COM#
EmonLib > LINEBOT * Select the correct port
Esp8266EasyloT I MAZE * Go to Device Manager
ESP8266wifi MOTOR_TEST if you're not sure.

Ethernet 1 SERVO_SWEEP
etherShield ; SUMO «—

2. Board select

Go to Tools>Boards>gizDuino (mini) w/ Atmega168 Tips for uploading:
* Press and Hold the RST (SW3)
prrr— oot switch ON the power and
o e & Reons Click Upload. Release RST
ot o oot when done.

WIiFi101 Firmware Updater
ArduBlock

Board: "Gizduino (mini) w/ ATmega168"
Port
Get Board Info

Programmer: "AVRISP mkll”
Burn Bootloader



e-G|zmo

MECHATRONIX CENTRA

SYNTAX

* PBOT.COL1_RIGHT();
* PBOT.COL2_CENTER();
* PBOT.COL3_LEFT();

\4

OUTPUT

* OBJECT DETECTED =1 or HIGH

EXAMPLES;

If (PBOT.COL2_CENTER() == HIGH) // if IR sensor 2 center is high
{

Serial.printin(“Object detected!”);

}



Servo Supply J2

Put a jumper

P
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Uploading Servo sweep.ino

On the Arduino IDE.
1. Maze Solver codes

Go to File>Examples>eGizmo_PB0T2018>
Servo_Sweep

¢ eGizmo_PBOT2018 ; AVOID_COLLISION
EmonLib : LINEBOT
Esp8266EasyloT 1 MAZE
ESP8266wifi : MOTOR_TEST
Ethernet ‘ SERVO_SWEEP D E—
etherShield SUMO

2. Board select
Go to Tools>Boards>gizDuino (mini) w/ Atmega168

Tools Help
Auto Format Ctr+T
Archive Sketch
Fix Encoding & Reload
Serial Monitor Ctrl+Shift+M
Serial Plotter Ctrl+5Shift+L

WIiFi101 Firmware Updater
ArduBlock

Board: "Gizduino (mini) w/ ATmega168"
Port
Get Board Info

Programmer: "AVRISP mkll”
Burn Bootloader

3. Port select
Go to Tools>Port>COM#
Select the correct port
Go to Device Manager
if you're not sure.

Tips for uploading:

Press and Hold the RST (SW3)
switch ON the power and
Click Upload. Release RST
when done.



SYNTAX

PBOT.SERVO(whichSERVO,pulsewidth);
where:
Whichservo =1to 4, ignore other values

Pulsewidth = 0 to 180 (degrees)
- value less than 500 stops the Servo PWM generator

- the pulsewidth converted to degrees from 0 to 180 (default)

EXAMPLES;

PBOT.SERVO(1, 15);
delay(1000);
PBOT.SERVo(1, 90);
delay(1000);
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Website:

* Egizmo Tech blog

* Facebook: eGizmoMechatronix

* Youtube Channel: e-Gizmo Mechatronix Central


http://www.e-gizmo.net/
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